summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--python2.patch50
3 files changed, 67 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcf146217ac7..f46eee768146 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
# Generated by mksrcinfo v8
-# Mon Nov 12 18:21:28 UTC 2018
+# Mon Nov 12 18:35:45 UTC 2018
pkgbase = munin-libvirt-git
pkgdesc = libvirt plugins for munin system monitoring
pkgver = r36.e3442fb
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MikeQG/munin-libvirt-plugins
arch = any
license = GPL2
makedepends = git
makedepends = pychecker
depends = munin-node
- depends = libvirt-python
- depends = python-lxml
+ depends = libvirt-python2
+ depends = python2-lxml
provides = munin-libvirt
conflicts = munin-libvirt
source = munin-libvirt::git+https://github.com/MikeQG/munin-libvirt-plugins.git
+ source = python2.patch
md5sums = SKIP
+ md5sums = 80bc3b1a35f821c97ba4f3ab88dbd7e3
pkgname = munin-libvirt-git
diff --git a/PKGBUILD b/PKGBUILD
index 1c0a55d528da..c30b981a7b91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Michael Taboada <michael@2mb.solutions>
pkgname=munin-libvirt-git
pkgver=r36.e3442fb
-pkgrel=1
+pkgrel=2
pkgdesc="libvirt plugins for munin system monitoring"
arch=(any)
url="https://github.com/MikeQG/munin-libvirt-plugins"
license=('GPL2')
-depends=('munin-node' 'libvirt-python' 'python-lxml')
+depends=('munin-node' 'libvirt-python2' 'python2-lxml')
makedepends=('git' 'pychecker')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('munin-libvirt::git+https://github.com/MikeQG/munin-libvirt-plugins.git')
-md5sums=('SKIP')
+source=('munin-libvirt::git+https://github.com/MikeQG/munin-libvirt-plugins.git'
+ 'python2.patch')
+md5sums=('SKIP'
+ '80bc3b1a35f821c97ba4f3ab88dbd7e3')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -19,6 +21,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 -i ../python2.patch
+}
+
build() {
cd "$srcdir/${pkgname%-git}"
make
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..43a2a5ffc714
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,50 @@
+diff --git a/libvirt-blkstat b/libvirt-blkstat
+index 42ec1b4..f7ac712 100644
+--- a/libvirt-blkstat
++++ b/libvirt-blkstat
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # vim: set fileencoding=utf-8 :
+ #
+ # Munin plugin to show the I/O load of libvirt managed virtual machines
+diff --git a/libvirt-cputime b/libvirt-cputime
+index f2d658d..68a0cc6 100644
+--- a/libvirt-cputime
++++ b/libvirt-cputime
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # vim: set fileencoding=utf-8 :
+ #
+ # Munin plugin to show the percent of cputime of libvirt managed virtual
+diff --git a/libvirt-ifstat b/libvirt-ifstat
+index d0134fc..067c1da 100644
+--- a/libvirt-ifstat
++++ b/libvirt-ifstat
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # vim: set fileencoding=utf-8 :
+ #
+ # Munin plugin to show the network traffic of libvirt managed virtual machines
+diff --git a/libvirt-mem b/libvirt-mem
+index cf9bd6b..ef3a063 100644
+--- a/libvirt-mem
++++ b/libvirt-mem
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # vim: set fileencoding=utf-8 :
+ #
+ # Munin plugin to show the amount of memory used by libvirt managed virtual
+diff --git a/munin-libvirt-plugins-detect.in b/munin-libvirt-plugins-detect.in
+index 275c987..7226f8e 100644
+--- a/munin-libvirt-plugins-detect.in
++++ b/munin-libvirt-plugins-detect.in
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # vim: set fileencoding=utf-8 :
+ #
+ # Configure and enable munin libvirt plugins