summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--cmm_ctx_gone.patch12
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1816d6dae16..27c96dcca53d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mupdf-git
pkgdesc = Lightweight PDF, XPS and CBZ viewer
- pkgver = 20170721.bc5284fb
+ pkgver = 20170912.b69387ac
pkgrel = 1
url = http://mupdf.com/
arch = i686
@@ -23,7 +23,7 @@ pkgbase = mupdf-git
source = desktop
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 4728d2e4906db23de93fdea23ec8c5c0e5a41cba5d7446195b9d84e11ef0635e
+ sha256sums = b24af44a9f88bcbe1fb649a8055817cfc6908e523b95417779726526a88041f9
sha256sums = 3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd
pkgname = mupdf-git
diff --git a/PKGBUILD b/PKGBUILD
index f887493a122c..78664d0d9da6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mupdf-git
_pkgname=mupdf
-pkgver=20170721.bc5284fb
+pkgver=20170912.b69387ac
pkgrel=1
pkgdesc='Lightweight PDF, XPS and CBZ viewer'
arch=('i686' 'x86_64' 'armv7h')
@@ -18,7 +18,7 @@ source=('git://git.ghostscript.com/mupdf.git'
'desktop')
sha256sums=('SKIP'
'SKIP'
- '4728d2e4906db23de93fdea23ec8c5c0e5a41cba5d7446195b9d84e11ef0635e'
+ 'b24af44a9f88bcbe1fb649a8055817cfc6908e523b95417779726526a88041f9'
'3240d4ebda002cb2c4f42cd42793c6160f1701d349d0acb797819dfd10d4fedd')
conflicts=("${_pkgname}")
diff --git a/cmm_ctx_gone.patch b/cmm_ctx_gone.patch
index 208256dcac4e..55ce3c56dc77 100644
--- a/cmm_ctx_gone.patch
+++ b/cmm_ctx_gone.patch
@@ -60,7 +60,7 @@ diff -ur old/source/fitz/color-lcms.c new/source/fitz/color-lcms.c
lcms_src_cs = 0;
- src_num_chan = cmsChannelsOf(cmm_ctx, src_cs);
+ src_num_chan = cmsChannelsOf(src_cs);
- src_data_type = (COLORSPACE_SH(lcms_src_cs) | CHANNELS_SH(src_num_chan) | DOSWAP_SH(src->bgr) | BYTES_SH(num_bytes) | EXTRA_SH(extras));
+ src_data_type = (COLORSPACE_SH(lcms_src_cs) | CHANNELS_SH(src_num_chan) | DOSWAP_SH(src->bgr) | BYTES_SH(num_bytes) | EXTRA_SH(src_extras));
/* dst */
- des_cs = cmsGetColorSpace(cmm_ctx, dst->cmm_handle);
@@ -71,10 +71,10 @@ diff -ur old/source/fitz/color-lcms.c new/source/fitz/color-lcms.c
lcms_des_cs = 0;
- des_num_chan = cmsChannelsOf(cmm_ctx, des_cs);
+ des_num_chan = cmsChannelsOf(des_cs);
- des_data_type = (COLORSPACE_SH(lcms_des_cs) | CHANNELS_SH(des_num_chan) | DOSWAP_SH(dst->bgr) | BYTES_SH(num_bytes) | EXTRA_SH(extras));
+ des_data_type = (COLORSPACE_SH(lcms_des_cs) | CHANNELS_SH(des_num_chan) | DOSWAP_SH(dst->bgr) | BYTES_SH(num_bytes) | EXTRA_SH(dst_extras));
/* flags */
-@@ -252,17 +252,17 @@
+@@ -254,17 +254,17 @@
cmsUInt32Number prf_data_type;
cmsHPROFILE hProfiles[3];
@@ -97,7 +97,7 @@ diff -ur old/source/fitz/color-lcms.c new/source/fitz/color-lcms.c
if (!src_to_prf_profile)
fz_throw(ctx, FZ_ERROR_GENERIC, "cmsTransform2DeviceLink failed");
-@@ -270,7 +270,7 @@
+@@ -272,7 +272,7 @@
hProfiles[1] = prf->cmm_handle;
hProfiles[2] = dst->cmm_handle;
link->cmm_handle = cmsCreateMultiprofileTransformTHR(cmm_ctx, hProfiles, 3, src_data_type, des_data_type, INTENT_RELATIVE_COLORIMETRIC, flag);
@@ -106,7 +106,7 @@ diff -ur old/source/fitz/color-lcms.c new/source/fitz/color-lcms.c
if (!link->cmm_handle)
fz_throw(ctx, FZ_ERROR_GENERIC, "cmsCreateMultiprofileTransform failed");
}
-@@ -285,7 +285,7 @@
+@@ -287,7 +287,7 @@
cmsContext cmm_ctx = (cmsContext)instance;
DEBUG_LCMS_MEM(("Free Link:: link = %p \n", (void*)link->cmm_handle));
if (link->cmm_handle != NULL)
@@ -115,7 +115,7 @@ diff -ur old/source/fitz/color-lcms.c new/source/fitz/color-lcms.c
link->cmm_handle = NULL;
}
-@@ -339,7 +339,7 @@
+@@ -341,7 +341,7 @@
cmsContext cmm_ctx = (cmsContext)instance;
DEBUG_LCMS_MEM(("Free Profile:: profile = %p \n", (void*) profile->cmm_handle));
if (profile->cmm_handle != NULL)