summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD59
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e74b2e187350
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = mupen64plus-highscore-git
+ pkgdesc = Highscore port of Mupen64Plus
+ pkgver = r25.b9b6bb3
+ pkgrel = 1
+ url = https://github.com/alice-mkh/mupen64plus-highscore
+ arch = x86_64
+ license = GPL-2.0-only
+ makedepends = git
+ makedepends = meson
+ makedepends = nasm
+ makedepends = yasm
+ depends = freetype2
+ depends = glu
+ depends = libgl
+ depends = libhighscore-git
+ depends = libpng
+ depends = sdl2
+ depends = zlib
+ provides = mupen64plus-highscore
+ conflicts = mupen64plus-highscore
+ options = !lto
+ source = git+https://github.com/alice-mkh/mupen64plus-highscore.git
+ source = git+https://github.com/mupen64plus/mupen64plus-core.git
+ source = git+https://github.com/gonetz/GLideN64.git
+ source = git+https://github.com/mupen64plus/mupen64plus-rsp-hle.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = mupen64plus-highscore-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..298a78d662b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=mupen64plus-highscore-git
+pkgver=r25.b9b6bb3
+pkgrel=1
+pkgdesc="Highscore port of Mupen64Plus"
+arch=('x86_64')
+url="https://github.com/alice-mkh/mupen64plus-highscore"
+license=('GPL-2.0-only')
+depends=(
+ 'freetype2'
+ 'glu'
+ 'libgl'
+ 'libhighscore-git'
+ 'libpng'
+ 'sdl2'
+ 'zlib'
+)
+makedepends=(
+ 'git'
+ 'meson'
+ 'nasm'
+ 'yasm'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!lto')
+source=('git+https://github.com/alice-mkh/mupen64plus-highscore.git'
+ 'git+https://github.com/mupen64plus/mupen64plus-core.git'
+ 'git+https://github.com/gonetz/GLideN64.git'
+ 'git+https://github.com/mupen64plus/mupen64plus-rsp-hle.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname%-git}"
+ git submodule init
+ git config submodule.libs/mupen64plus-core.url "$srcdir/mupen64plus-core"
+ git config submodule.libs/GLideN64.url "$srcdir/GLideN64"
+ git config submodule.libs/mupen64plus-rsp-hle.url "$srcdir/mupen64plus-rsp-hle"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+# CFLAGS+=" -ffat-lto-objects"
+# CXXFLAGS+=" -ffat-lto-objects"
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}