summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e7fa5901162
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Wed Dec 23 03:59:18 UTC 2015
+pkgbase = music_dropper-git
+ pkgdesc = A simple method of moving music from your PC, onto your Windows Phone device, over wireless (including automatic conversion).
+ pkgver = 4
+ pkgrel = 1
+ url = https://github.com/samcamwilliams/music_dropper.git
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = ffmpeg
+ depends = erlang
+ depends = curl
+ optdepends = flac: for automatic conversion of FLAC to 320kbps MP3
+ source = git+https://github.com/samcamwilliams/music_dropper.git
+ md5sums = SKIP
+
+pkgname = music_dropper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8aa09f7ff08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sam Williams <samuel.ecwilliams on Gmail>
+pkgname=music_dropper-git
+pkgver=4
+pkgrel=1
+pkgdesc="A simple method of moving music from your PC, onto your Windows Phone device, over wireless (including automatic conversion)."
+arch=('any')
+url="https://github.com/samcamwilliams/music_dropper.git"
+license=('GPLv2')
+depends=('ffmpeg' 'erlang' 'curl')
+optdepends=('flac: for automatic conversion of FLAC to 320kbps MP3')
+makedepends=('git')
+source=('git+https://github.com/samcamwilliams/music_dropper.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/music_dropper"
+ # Use the tag of the last commit
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "$srcdir/music_dropper"
+ install -m755 -D music_dropper $pkgdir/usr/bin/music_dropper
+}