summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--LICENSE.txt29
-rw-r--r--PKGBUILD30
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a97e0f0effcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = musikcube
+ pkgdesc = A terminal-based cross-platform music player, audio engine, metadata indexer, and server
+ pkgver = 0.22.0
+ pkgrel = 1
+ url = https://github.com/clangen/musikcube
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = faad2
+ depends = libogg
+ depends = libvorbis
+ depends = flac
+ depends = libmicrohttpd
+ depends = lame
+ depends = ncurses
+ depends = boost
+ depends = pulseaudio
+ depends = libpulse
+ depends = alsa-lib
+ depends = curl
+ conflicts = musikcube-git
+ source = https://github.com/clangen/musikcube/archive/0.22.0.tar.gz
+ source = LICENSE.txt
+ sha256sums = 0a252973378b1f21fbdc7646dfae3d8113f8572c186bed4b129c6725ea4ec6a2
+ sha256sums = f6b4cd2e08c8a93cd447eb4a077ecb0c7eca8c3d175aaeedb1f49731f86c8e5b
+
+pkgname = musikcube
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..cacaf6bf9884
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,29 @@
+Copyright (c) 2007-2017 musikcube team
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+ * Neither the name of the author nor the names of other contributors may
+ be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..516b30128ba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+
+pkgname=musikcube
+pkgver=0.22.0
+pkgrel=1
+pkgdesc="A terminal-based cross-platform music player, audio engine, metadata indexer, and server"
+arch=('x86_64')
+url="https://github.com/clangen/$pkgname"
+license=('BSD')
+conflicts=("$pkgname-git")
+depends=('faad2' 'libogg' 'libvorbis' 'flac' 'libmicrohttpd' 'lame' 'ncurses' 'boost' 'pulseaudio' 'libpulse' 'alsa-lib' 'curl')
+makedepends=('cmake')
+source=(https://github.com/clangen/musikcube/archive/$pkgver.tar.gz
+ LICENSE.txt)
+sha256sums=('0a252973378b1f21fbdc7646dfae3d8113f8572c186bed4b129c6725ea4ec6a2'
+ 'f6b4cd2e08c8a93cd447eb4a077ecb0c7eca8c3d175aaeedb1f49731f86c8e5b')
+
+build() {
+ cd $pkgname-$pkgver
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+ install -Dm644 $srcdir/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}