summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE.txt29
-rw-r--r--PKGBUILD22
3 files changed, 13 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 218585e23075..3dc66b4d91e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = musikcube
pkgdesc = A terminal-based cross-platform music player, audio engine, metadata indexer, and server
- pkgver = 0.42.0
+ pkgver = 0.50.0
pkgrel = 1
url = https://github.com/clangen/musikcube
arch = x86_64
@@ -20,10 +20,8 @@ pkgbase = musikcube
depends = alsa-lib
depends = curl
conflicts = musikcube-git
- source = https://github.com/clangen/musikcube/archive/0.42.0.tar.gz
- source = LICENSE.txt
- sha256sums = da23cf524160f874c07fe0dbaf52447abb910ab7aba57aa0599ded7519371d0c
- sha256sums = f6b4cd2e08c8a93cd447eb4a077ecb0c7eca8c3d175aaeedb1f49731f86c8e5b
+ source = https://github.com/clangen/musikcube/archive/0.50.0.tar.gz
+ sha256sums = ffb580937c8914f13e7ea804a05d6d024639109d981220a97ffa57d9396b2336
pkgname = musikcube
diff --git a/LICENSE.txt b/LICENSE.txt
deleted file mode 100644
index cacaf6bf9884..000000000000
--- a/LICENSE.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-Copyright (c) 2007-2017 musikcube team
-
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
- * Redistributions of source code must retain the above copyright notice,
- this list of conditions and the following disclaimer.
-
- * Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
-
- * Neither the name of the author nor the names of other contributors may
- be used to endorse or promote products derived from this software
- without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
-LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
-SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
-CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 900adc4336c1..5491b92b7b70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,28 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=musikcube
-pkgver=0.42.0
+pkgver=0.50.0
pkgrel=1
-pkgdesc="A terminal-based cross-platform music player, audio engine, metadata indexer, and server"
+pkgdesc='A terminal-based cross-platform music player, audio engine, metadata indexer, and server'
arch=('x86_64')
-url="https://github.com/clangen/$pkgname"
+url="https://github.com/clangen/${pkgname}"
license=('BSD')
-conflicts=("$pkgname-git")
+conflicts=("${pkgname}-git")
depends=('faad2' 'libogg' 'libvorbis' 'flac' 'libmicrohttpd' 'lame' 'ncurses' 'boost' 'pulseaudio' 'libpulse' 'libev' 'alsa-lib' 'curl')
makedepends=('cmake')
-source=(https://github.com/clangen/musikcube/archive/$pkgver.tar.gz
- LICENSE.txt)
-sha256sums=('da23cf524160f874c07fe0dbaf52447abb910ab7aba57aa0599ded7519371d0c'
- 'f6b4cd2e08c8a93cd447eb4a077ecb0c7eca8c3d175aaeedb1f49731f86c8e5b')
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('ffb580937c8914f13e7ea804a05d6d024639109d981220a97ffa57d9396b2336')
build() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}
package() {
- cd $pkgname-$pkgver
+ cd "${pkgname}-${pkgver}"
- make DESTDIR=$pkgdir install
- install -Dm644 $srcdir/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}