summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa380dace64d..05902c113b20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = musique
pkgdesc = A finely crafted music player
- pkgver = 1.11
+ pkgver = 1.12
pkgrel = 1
url = https://flavio.tordini.org/musique
arch = x86_64
license = GPL3
makedepends = git
- makedepends = qt5-tools
- depends = qt5-declarative
+ makedepends = qt6-tools
+ depends = qt6-declarative
depends = taglib
depends = mpv
optdepends = finetune
- source = git+https://github.com/flaviotordini/musique.git#tag=1.11
+ source = git+https://github.com/flaviotordini/musique.git#tag=1.12
source = git+https://github.com/flaviotordini/http.git
source = git+https://github.com/flaviotordini/idle.git
source = git+https://github.com/flaviotordini/media.git
diff --git a/PKGBUILD b/PKGBUILD
index a01387081bfa..98a831b0cf0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,15 @@
# Contributor: dieghen89 <dieghen89 at gmail dot com>
pkgname=musique
-pkgver=1.11
+pkgver=1.12
pkgrel=1
pkgdesc='A finely crafted music player'
arch=('x86_64')
url='https://flavio.tordini.org/musique'
_giturl='https://github.com/flaviotordini'
license=('GPL3')
-depends=('qt5-declarative' 'taglib' 'mpv')
-makedepends=('git' 'qt5-tools')
+depends=('qt6-declarative' 'taglib' 'mpv')
+makedepends=('git' 'qt6-tools')
optdepends=('finetune')
source=("git+${_giturl}/musique.git#tag=${pkgver}"
"git+${_giturl}/http.git"
@@ -45,7 +45,8 @@ prepare() {
}
build() {
- qmake-qt5 $pkgname PREFIX=/usr
+ PATH="$PATH:/usr/lib/qt6/bin"
+ qmake6 $pkgname PREFIX=/usr
make
}