summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd1555d882a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mustang-plug-qt5
+ pkgdesc = Software for Fender Mustang Amps. Forked from piorekf/plug.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://gitlab.com/offa/plug
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = cmake
+ makedepends = gtest
+ makedepends = gmock
+ makedepends = git
+ depends = qt5-base
+ depends = libusb
+ provides = mustang-plug-qt5-work
+ conflicts = mustang-plug-qt5-work
+ source = https://gitlab.com/offa/plug/-/archive/v1.4.0/plug-v1.4.0.tar.bz2
+ md5sums = 7734568324a76aa2df668eccf7347067
+
+pkgname = mustang-plug-qt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edacc504c72b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Author: tgommes <tgommes@gmail.com>
+pkgname=mustang-plug-qt5
+pkgver="1.4.0"
+pkgrel="1"
+pkgdesc="Software for Fender Mustang Amps. Forked from piorekf/plug."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/offa/plug"
+license=('GPLv3')
+depends=('qt5-base' 'libusb')
+makedepends=('cmake' 'gtest' 'gmock' 'git')
+provides=('mustang-plug-qt5-work')
+conflicts=('mustang-plug-qt5-work')
+# source=("git+git://git://gitlab.com/offa/plug")
+source=("https://gitlab.com/offa/plug/-/archive/v${pkgver}/plug-v${pkgver}.tar.bz2")
+md5sums=('7734568324a76aa2df668eccf7347067')
+
+build() {
+ cd "$srcdir/plug-v${pkgver}"
+ mkdir build && cd build
+
+ cmake ..
+ make
+ make unittest
+}
+
+package() {
+ cd "$srcdir/plug-v${pkgver}/build"
+ make DESTDIR="$pkgdir" install
+
+ # Adjust pathes to arch
+ mv "$pkgdir"/lib "$pkgdir"/usr/
+ mv "$pkgdir"/usr/local/bin "$pkgdir"/usr/
+ rm -rf "$pkgdir"/usr/local
+}
+