summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--365.patch14
-rw-r--r--PKGBUILD24
3 files changed, 34 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe208bdd63df..bd9ff6e92a59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mutter-781835-workaround
pkgdesc = A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included.
pkgver = 3.30.2+7
- pkgrel = 10
+ pkgrel = 11
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
groups = gnome
@@ -30,12 +30,14 @@ pkgbase = mutter-781835-workaround
source = git+https://gitlab.gnome.org/GNOME/mutter.git#commit=bcd6103c44ff74ebffd1737b8e0f3a952b83bd54
source = 216.patch
source = 318.patch
+ source = 365.patch
source = https://gitlab.gnome.org/GNOME/mutter/merge_requests/347.patch
source = startup-notification.patch
source = revert.patch
sha256sums = SKIP
sha256sums = 1ae59343f3f5838babdfe1400962bb315d8b49189deb05bb516966b922cd26a5
sha256sums = d4dcffa9c407e60e321670caaa44dcd6e2bfda7221d73ec4145a985c825a43b3
+ sha256sums = a0c86a5770e34973e074dd542dd1c4abb3b7e45b7a429a8aa6a7d1e73df39796
sha256sums = 1343ed3c21ca7ab4f179b864eae4b915b910406c3eb8259399973c29822f751c
sha256sums = 00d5e77c94e83e1987cc443ed7c47303aa33367ce912b2f665bcd34f88890a17
sha256sums = 2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09
diff --git a/365.patch b/365.patch
new file mode 100644
index 000000000000..0500009f5798
--- /dev/null
+++ b/365.patch
@@ -0,0 +1,14 @@
+diff --git a/clutter/clutter/clutter-stage.c b/clutter/clutter/clutter-stage.c
+index e7dea4292..103a99cd6 100644
+--- a/clutter/clutter/clutter-stage.c
++++ b/clutter/clutter/clutter-stage.c
+@@ -1564,7 +1564,8 @@ _clutter_stage_do_pick_on_view (ClutterStage *stage,
+ */
+ cogl_push_framebuffer (fb);
+ context->pick_mode = mode;
+- _clutter_stage_paint_view (stage, view, NULL);
++
++ clutter_stage_do_paint_view (stage, view, NULL);
+ context->pick_mode = CLUTTER_PICK_NONE;
+ priv->cached_pick_mode = mode;
+ cogl_pop_framebuffer ();
diff --git a/PKGBUILD b/PKGBUILD
index c02c907e597e..90e0f84df5fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _revert=1
pkgname=mutter-781835-workaround
_pkgname=mutter
pkgver=3.30.2+7
-pkgrel=10
+pkgrel=11
pkgdesc="A window manager for GNOME. This package reverts a commit which may causes performance problems for nvidia driver users. Some performance patches also included."
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -29,13 +29,14 @@ conflicts=(mutter)
groups=(gnome)
_commit=bcd6103c44ff74ebffd1737b8e0f3a952b83bd54 # tags/3.30.2^0
source=("git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
- 216.patch 318.patch
+ 216.patch 318.patch 365.patch
https://gitlab.gnome.org/GNOME/mutter/merge_requests/347.patch
startup-notification.patch
revert.patch)
sha256sums=('SKIP'
'1ae59343f3f5838babdfe1400962bb315d8b49189deb05bb516966b922cd26a5'
'd4dcffa9c407e60e321670caaa44dcd6e2bfda7221d73ec4145a985c825a43b3'
+ 'a0c86a5770e34973e074dd542dd1c4abb3b7e45b7a429a8aa6a7d1e73df39796'
'1343ed3c21ca7ab4f179b864eae4b915b910406c3eb8259399973c29822f751c'
'00d5e77c94e83e1987cc443ed7c47303aa33367ce912b2f665bcd34f88890a17'
'2d2e305e0a6cca087bb8164f81bdc0ae7a5ca8e9c13c81d7fd5252eb3563fc09')
@@ -56,8 +57,7 @@ prepare() {
# clutter: Deliver events sooner when possible
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/168
- # Disabled as may cause stutter when using mouse with high polling rate
- # git cherry-pick 7782ed6e
+ git cherry-pick cd280c30
# clutter: Fix offscreen-effect painting of clones
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/117/commits
@@ -90,9 +90,13 @@ prepare() {
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/353/commits
git cherry-pick 8d514095
- # cogl-winsys-glx: Fix frame notification race/leak [performance]
- # https://gitlab.gnome.org/GNOME/mutter/merge_requests/216
- git cherry-pick 335993f7
+ # Avoid some parent actor relayouts/redraws
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/202
+ git cherry-pick 9a843857^..ffaec917
+
+ # Unassorted performance fixes
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/195
+ git cherry-pick a7df4594..1d73533f
# '
# Commented multiline comment end, remove the # above if disabling the patches
@@ -102,12 +106,18 @@ prepare() {
patch -Np1 -i ../revert.patch
fi
+ # cogl-winsys-glx: Fix frame notification race/leak [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/216
git apply -3 ../216.patch
+ #Sync to the hardware refresh rate, not just 60.00Hz [performance]
# https://gitlab.gnome.org/GNOME/mutter/merge_requests/318
git apply -3 ../318.patch
+ # clutter-stage: Don't emit "after-paint" when picking [performance]
+ # https://gitlab.gnome.org/GNOME/mutter/merge_requests/365
+ git apply -3 ../365.patch
+
# https://bugs.archlinux.org/task/51940
# As of 2018-05-08: Still needed, according to fmuellner
git apply -3 ../startup-notification.patch