summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--revert.patch32
3 files changed, 39 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 240508ebca2f..13a872abf253 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,8 +28,10 @@ pkgbase = mutter
options = !emptydirs
source = git+https://git.gnome.org/browse/mutter#commit=0e154ccf76aeb97c7e4b541322b4a1e898609936
source = startup-notification.patch
+ source = revert.patch
sha256sums = SKIP
sha256sums = 5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366
+ sha256sums = 07f87412f2a24dc03fab95eb8aba437fad0927aad844db0557c193c811e03f88
pkgname = mutter
diff --git a/PKGBUILD b/PKGBUILD
index 7f1ed9f529e9..58c995642ffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,9 +18,11 @@ groups=(gnome)
options=(!emptydirs)
_commit=0e154ccf76aeb97c7e4b541322b4a1e898609936 # tags/3.26.1^0
source=("git+https://git.gnome.org/browse/mutter#commit=$_commit"
- startup-notification.patch)
+ startup-notification.patch
+ revert.patch)
sha256sums=('SKIP'
- '5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366')
+ '5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366'
+ '07f87412f2a24dc03fab95eb8aba437fad0927aad844db0557c193c811e03f88')
pkgver() {
cd $pkgname
@@ -32,6 +34,7 @@ prepare() {
# https://bugs.archlinux.org/task/51940
patch -Np1 -i ../startup-notification.patch
+ patch -Np1 -i ../revert.patch
NOCONFIGURE=1 ./autogen.sh
}
diff --git a/revert.patch b/revert.patch
new file mode 100644
index 000000000000..73da0c36433d
--- /dev/null
+++ b/revert.patch
@@ -0,0 +1,32 @@
+--- a/src/backends/x11/meta-backend-x11.c 2017-04-18 12:12:13.502104430 +0300
++++ b/src/backends/x11/meta-backend-x11.c 2017-04-18 12:17:36.020693209 +0300
+@@ -605,12 +605,6 @@
+ static void
+ meta_backend_x11_init (MetaBackendX11 *x11)
+ {
+- /* XInitThreads() is needed to use the "threaded swap wait" functionality
+- * in Cogl - see meta_renderer_x11_create_cogl_renderer(). We call it here
+- * to hopefully call it before any other use of XLib.
+- */
+- XInitThreads();
+-
+ clutter_x11_request_reset_on_video_memory_purge ();
+
+ /* We do X11 event retrieval ourselves */
+
+--- a/src/backends/x11/meta-renderer-x11.c 2017-04-18 12:12:13.502104430 +0300
++++ b/src/backends/x11/meta-renderer-x11.c 2017-04-18 12:20:34.369354522 +0300
+@@ -74,14 +74,6 @@
+ cogl_renderer_set_custom_winsys (cogl_renderer, get_x11_cogl_winsys_vtable);
+ cogl_xlib_renderer_set_foreign_display (cogl_renderer, xdisplay);
+
+- /* Set up things so that if the INTEL_swap_event extension is not present,
+- * but the driver is known to have good thread support, we use an extra
+- * thread and call glXWaitVideoSync() in the thread. This allows idles
+- * to work properly, even when Mutter is constantly redrawing new frames;
+- * otherwise, without INTEL_swap_event, we'll just block in glXSwapBuffers().
+- */
+- cogl_xlib_renderer_set_threaded_swap_wait_enabled (cogl_renderer, TRUE);
+-
+ return cogl_renderer;
+ }