summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--muximux.install9
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e74f54dfb381
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = muximux
+ pkgdesc = A Lightweight portal to your webapps
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/mescon/Muximux
+ install = muximux.install
+ arch = any
+ license = GPL2
+ depends = php
+ optdepends = apache: Web server to run Muximux
+ optdepends = nginx: Web server to run Muximux
+ optdepends = cherokee: Web server to run Muximux
+ source = https://github.com/mescon/Muximux/archive/v2.0.tar.gz
+ sha256sums = 5d422c2de809a7d69036ac877c3bd1034298dad2ab436637b25b973fc1bd95db
+
+pkgname = muximux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e13537571430
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Scott Dickson <scottfoesho@gmail.com>
+
+pkgname=muximux
+pkgver=2.0
+pkgrel=1
+pkgdesc='A Lightweight portal to your webapps'
+arch=('any')
+url='https://github.com/mescon/Muximux'
+license=('GPL2')
+depends=('php')
+optdepends=('apache: Web server to run Muximux'
+ 'nginx: Web server to run Muximux'
+ 'cherokee: Web server to run Muximux')
+install="$pkgname.install"
+source=("https://github.com/mescon/Muximux/archive/v${pkgver}.tar.gz")
+sha256sums=('5d422c2de809a7d69036ac877c3bd1034298dad2ab436637b25b973fc1bd95db')
+
+package() {
+ cd "${srcdir}/Muximux-$pkgver"
+ install -d "$pkgdir/usr/share/webapps/muximux"
+ cp -r . "$pkgdir/usr/share/webapps/muximux/"
+}
diff --git a/muximux.install b/muximux.install
new file mode 100644
index 000000000000..9c4dd0fbbe78
--- /dev/null
+++ b/muximux.install
@@ -0,0 +1,9 @@
+post_install() {
+ # Make data writable by webserver
+ chown -R http:http /usr/share/webapps/muximux
+ echo 'You can now configure your (PHP compatible) web server to run Muximux'
+}
+
+post_upgrade() {
+ post_install
+}