summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD26
-rw-r--r--mycroft-core.install7
4 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e2dc9ff8d48..cd4eda5ab762 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 27 12:43:51 UTC 2016
+# Fri Dec 30 11:12:17 UTC 2016
pkgbase = mycroft-core
pkgdesc = Mycroft Core, the Mycroft Artificial Intelligence platform. Contribute to this package at: https://gitlab.com/rafamanzo/aur-mycroft-core
- pkgver = 0.7.20.eb0a37c
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/MycroftAI/mycroft-core
install = mycroft-core.install
@@ -30,12 +30,12 @@ pkgbase = mycroft-core
depends = curl
depends = mimic-git
depends = alsa-utils
- source = git://github.com/MycroftAI/mycroft-core.git#commit=eb0a37c
+ source = https://codeload.github.com/MycroftAI/mycroft-core/tar.gz/release/v0.8.0
source = mycroft.target
source = mycroft-service.service
source = mycroft-skills.service
source = mycroft-voice.service
- sha512sums = SKIP
+ sha512sums = e2a3044a482cff7a2d68451aba7e776e4f8d5236d6e00add4977354565b91c177753abd22048c24b5ffc28d9664bb38d00a73f199ff184ed8f5a19b912ec9305
sha512sums = a5989c9ff2b0f7338b4a6f9342c980413d71da375355abb416dce3a79e298fea7872e39b6a1505437aab860ed66755a6f344821f4f7cb31aed46792b2cef3f96
sha512sums = 74e9451dc38560e6efd4baf8c77cb81bdf9c0b821c1935eb2dac060614c0f14458101151583c3f444da59d9f065a744a7ad6f8daaeceec8f4e37f67d33199b6b
sha512sums = cb8a5c2245ecd52e66acedebf7ce6ce8db32a84b3495d34cc3749e03aa7d12c958b5f71fa01aa79b36906401e655dd6442e979d60d53d64160d9f956551a92df
diff --git a/.gitignore b/.gitignore
index d98522ed3103..e63a25db87b1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
*.pkg.tar.xz
mycroft-core/
+v* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 02f0c2251ca5..1d33768bc238 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Rafael Reggiani Manzo <rr.manzo#protonmail.com>
pkgname=mycroft-core
-_pkgcommit=eb0a37c
-pkgver=0.7.20.${_pkgcommit}
+# _pkgcommit=eb0a37c # Used only when the latest tag is not working
+# pkgver=0.7.20.${_pkgcommit}
+pkgver=0.8.0
pkgrel=1
pkgdesc="Mycroft Core, the Mycroft Artificial Intelligence platform. Contribute to this package at: https://gitlab.com/rafamanzo/aur-mycroft-core"
arch=('i686' 'x86_64')
@@ -33,35 +34,38 @@ optdepends=()
conflicts=()
install=mycroft-core.install
# changelog=ChangeLog
-# FIXME: The tarball is outdated and not able to pair with home.mycroft.ai
-#source=("https://codeload.github.com/MycroftAI/mycroft-core/tar.gz/release/${pkgver}")
-#sha512sums=('cd86a76b4131db1b5a172b617ee8ff46d60b8094b8dec9e3a88fe976f7d6c4d9b65b44fd62984d1ce5c8c761f15a341291677b9c1bccc50fead80727b474bca5')
-source=("git://github.com/MycroftAI/mycroft-core.git#commit=${_pkgcommit}"
+source=("https://codeload.github.com/MycroftAI/mycroft-core/tar.gz/release/v${pkgver}"
+#source=("git://github.com/MycroftAI/mycroft-core.git#commit=${_pkgcommit}" # Used only when the latest tag is not working
"mycroft.target"
"mycroft-service.service"
"mycroft-skills.service"
"mycroft-voice.service")
-sha512sums=(SKIP # Git already ensures data consistency
+sha512sums=(e2a3044a482cff7a2d68451aba7e776e4f8d5236d6e00add4977354565b91c177753abd22048c24b5ffc28d9664bb38d00a73f199ff184ed8f5a19b912ec9305
+# sha512sums=(SKIP # Git already ensures data consistency # Used only when the latest tag is not working
a5989c9ff2b0f7338b4a6f9342c980413d71da375355abb416dce3a79e298fea7872e39b6a1505437aab860ed66755a6f344821f4f7cb31aed46792b2cef3f96
74e9451dc38560e6efd4baf8c77cb81bdf9c0b821c1935eb2dac060614c0f14458101151583c3f444da59d9f065a744a7ad6f8daaeceec8f4e37f67d33199b6b
cb8a5c2245ecd52e66acedebf7ce6ce8db32a84b3495d34cc3749e03aa7d12c958b5f71fa01aa79b36906401e655dd6442e979d60d53d64160d9f956551a92df
7266494bf416a6f969bcbe9e854753e2a7e498ff9b43d6ca0ba37d94736bca9bf35f5825f24e19138428728189814222f2592fdea4c7e1d0d0ad18e7d3606a0b)
# Valid only when using a tarball
-# prepare(){
-# tar xzfv "${pkgver}"
-# }
+prepare(){
+ tar xzfv v${pkgver}
+}
# build() {}
package() {
mkdir -p ${pkgdir}/usr/share/
- cp -R mycroft-core ${pkgdir}/usr/share/
+ # cp -R mycroft-core ${pkgdir}/usr/share/ # Used only when the latest tag is not working
+ cp -R mycroft-core-release-v${pkgver} ${pkgdir}/usr/share/mycroft-core
# Place a link to mimic where mycroft is expecting it
mkdir -p ${pkgdir}/usr/share/mycroft-core/mimic/bin
ln -s /usr/bin/mimic ${pkgdir}/usr/share/mycroft-core/mimic/bin/mimic
+ # Set permissions
+ chmod g+w ${pkgdir}/usr/share/mycroft-core
+
# Symtemd units
install -D -m644 "${srcdir}/mycroft.target" "${pkgdir}/usr/lib/systemd/user/mycroft.target"
install -D -m644 "${srcdir}/mycroft-service.service" "${pkgdir}/usr/lib/systemd/user/mycroft-service.service"
diff --git a/mycroft-core.install b/mycroft-core.install
index 3ccd7bea8630..3a5ed0796c94 100644
--- a/mycroft-core.install
+++ b/mycroft-core.install
@@ -4,7 +4,6 @@ pre_install() {
post_install() {
chown -R mycroft-core:mycroft-core /usr/share/mycroft-core
- chmod g+w /usr/share/mycroft-core
touch /usr/share/mycroft-core/.bashrc
echo "# Virtualenv initialization" >> /usr/share/mycroft-core/.bashrc
@@ -37,7 +36,13 @@ post_install() {
}
post_upgrade() {
+ chown -R mycroft-core:mycroft-core /usr/share/mycroft-core
sudo -u mycroft-core bash -c "source ~/.bashrc && workon mycroft && pip install -r /usr/share/mycroft-core/requirements.txt"
+
+ echo "*** ATTENTION ***"
+ echo ""
+ echo "* Upgrading to version v0.8.0 without repairing requires to each of Mycroft's user to run:"
+ echo " cp ~/.mycroft/identity/identity.json ~/.mycroft/identity/identity2.json"
}
post_remove() {