summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD23
2 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3548999007e4..8b19671e1196 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mynotes
pkgdesc = Desktop post-it / sticky notes managed from system tray icon
- pkgver = 2.3.3
+ pkgver = 2.4.0
pkgrel = 1
url = https://github.com/j4321/MyNotes
arch = any
@@ -11,15 +11,17 @@ pkgbase = mynotes
depends = python-pillow
depends = gettext
depends = desktop-file-utils
- optdepends = python-tkfilebrowser: nicer file browser,
- optdepends = zenity: nicer file browser,
optdepends = tktray: GUI toolkit for the system tray icon (at least one must be installed),
optdepends = pygtk: GUI toolkit for the system tray icon (at least one must be installed),
optdepends = python-pyqt5: GUI toolkit for the system tray icon (at least one must be installed),
optdepends = python-pyqt4: GUI toolkit for the system tray icon (at least one must be installed),
- optdepends = python-pyside: GUI toolkit for the system tray icon (at least one must be installed)
- source = mynotes-2.3.3.tar.gz::https://github.com/j4321/MyNotes/archive/v2.3.3.tar.gz
- sha512sums = 243a10ee1d1485a94eb3f46fefc4de59b898786d127495f24dc734589de13aecc402de4a3e01609b760aa3439978e6759fa0ea10ee7c9fd31ef7ca80090b782b
+ optdepends = python-pyside: GUI toolkit for the system tray icon (at least one must be installed),
+ optdepends = python-tkfilebrowser: nicer file browser,
+ optdepends = zenity: nicer file browser,
+ optdepends = texlive-bin: basic LaTeX formula support,
+ optdepends = python-matplotlib: basic LaTeX formula support
+ source = mynotes-2.4.0.tar.gz::https://github.com/j4321/MyNotes/archive/v2.4.0.tar.gz
+ sha512sums = 93082ca5675e6768d2992fb907e67732baef8053b9dc7e6903b5115cdfd772afccd4b363841c5104c7599b6e868e32f002522fff11d6188dac8acfedbb615dc6
pkgname = mynotes
diff --git a/PKGBUILD b/PKGBUILD
index 742fde8d10af..7ec3ba32879b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=mynotes
-pkgver=2.3.3
+pkgver=2.4.0
pkgrel=1
pkgdesc="Desktop post-it / sticky notes managed from system tray icon"
arch=('any')
@@ -8,17 +8,24 @@ url="https://github.com/j4321/MyNotes"
license=('GPL3')
makedepends=('python-setuptools')
depends=('tk' 'python-ewmh' 'python-pillow' 'gettext' 'desktop-file-utils')
-optdepends=('python-tkfilebrowser: nicer file browser',
- 'zenity: nicer file browser',
- 'tktray: GUI toolkit for the system tray icon (at least one must be installed)',
+optdepends=('tktray: GUI toolkit for the system tray icon (at least one must be installed)',
'pygtk: GUI toolkit for the system tray icon (at least one must be installed)',
'python-pyqt5: GUI toolkit for the system tray icon (at least one must be installed)',
'python-pyqt4: GUI toolkit for the system tray icon (at least one must be installed)',
- 'python-pyside: GUI toolkit for the system tray icon (at least one must be installed)')
+ 'python-pyside: GUI toolkit for the system tray icon (at least one must be installed)',
+ 'python-tkfilebrowser: nicer file browser',
+ 'zenity: nicer file browser',
+ 'texlive-bin: basic LaTeX formula support',
+ 'python-matplotlib: basic LaTeX formula support')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/j4321/MyNotes/archive/v${pkgver}.tar.gz")
-sha512sums=('243a10ee1d1485a94eb3f46fefc4de59b898786d127495f24dc734589de13aecc402de4a3e01609b760aa3439978e6759fa0ea10ee7c9fd31ef7ca80090b782b')
+sha512sums=('93082ca5675e6768d2992fb907e67732baef8053b9dc7e6903b5115cdfd772afccd4b363841c5104c7599b6e868e32f002522fff11d6188dac8acfedbb615dc6')
+
+build() {
+ cd "$srcdir/MyNotes-${pkgver}"
+ python setup.py build
+}
package() {
- cd "$srcdir/MyNotes-${pkgver}"
- python3 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1;
+ cd "$srcdir/MyNotes-${pkgver}"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}