summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820aaf456d34..990a262a493b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = mynotex
- pkgdesc = free note-taking and notes manager software for Linux
+ pkgdesc = A free note-taking, document file and activity manager for GNU/Linux
pkgver = 1.4.1.0
- pkgrel = 1
- url = http://sites.google.com/site/mynotex
+ pkgrel = 5
+ url = https://sites.google.com/site/mynotex
arch = i686
arch = x86_64
license = GPL
depends = sqlite3
depends = gtk2
- source_i686 = https://sites.google.com/site/mynotex/files/mynotex_1.4.1.0_i386.deb
- md5sums_i686 = 5ccdee9c57ef13a9e4902b97e86bc833
- source_x86_64 = https://sites.google.com/site/mynotex/files/mynotex_1.4.1.0_amd64.deb
- md5sums_x86_64 = 657979d34ffe42af2da902894825e2cf
+ optdepends = gnupg: for notes encryption
pkgname = mynotex
-
diff --git a/PKGBUILD b/PKGBUILD
index c86efa53b223..35cf4dbb86f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,38 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
# Contributor: saxonbeta <saxonbeta at gmail>
# Contributor: goten002 <goten002@gmail.com>
# Contributor: epinull
pkgname=mynotex
pkgver=1.4.1.0
-pkgrel=1
-pkgdesc="free note-taking and notes manager software for Linux"
-url="http://sites.google.com/site/mynotex"
+pkgrel=5
+pkgdesc="A free note-taking, document file and activity manager for GNU/Linux"
+url="https://sites.google.com/site/mynotex"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sqlite3' 'gtk2')
-source_i686=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_i386.deb")
-source_x86_64=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_amd64.deb")
-md5sums_i686=('5ccdee9c57ef13a9e4902b97e86bc833')
-md5sums_x86_64=('657979d34ffe42af2da902894825e2cf')
+optdepends=('gnupg: for notes encryption')
+gdrive_download() {
+ gUrl=https://drive.google.com/uc?export=download
+ curl -sc gc "${gUrl}&id=${1}" >/dev/null
+ curl -k -C - -Lb gc "${gUrl}&confirm=t&id=${1}" -o $2
+}
+
+prepare() {
+ if [ "$(uname -m | grep '64')" = "x86_64" ]; then
+ file=mynotex_1.4.1.0_amd64.deb
+ sha256=0026f7182fd0f9c38b6c220a3ea82642d93241f78ba33360f0d66270bf9f8673
+ gdrive_download 1emkXcCopQJkgpI2ehYpF1smz4vlsLz7L $file
+ else
+ file=mynotex_1.4.1.0_i386.deb
+ sha256=7a2b049d166609bec364e34ddf9899ff218c2fea410014f0af78472ee0fb4b90
+ gdrive_download 1qlwYZ2rLrvbzMp1ap6NfPzZGpbwqZk6K $file
+ fi
+
+ echo "$sha256 $file"|sha256sum -c
+ bsdtar xf $file
+}
package() {
tar -axf data.tar.xz -C "$pkgdir"