summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820aaf456d34..56d6e0425485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = mynotex
- pkgdesc = free note-taking and notes manager software for Linux
+ pkgdesc = A free note-taking, document file and activity manager for GNU/Linux
pkgver = 1.4.1.0
- pkgrel = 1
- url = http://sites.google.com/site/mynotex
+ pkgrel = 2
+ url = https://sites.google.com/site/mynotex
arch = i686
arch = x86_64
license = GPL
depends = sqlite3
depends = gtk2
+ optdepends = gnupg: for notes encryption
source_i686 = https://sites.google.com/site/mynotex/files/mynotex_1.4.1.0_i386.deb
- md5sums_i686 = 5ccdee9c57ef13a9e4902b97e86bc833
+ sha256sums_i686 = 7a2b049d166609bec364e34ddf9899ff218c2fea410014f0af78472ee0fb4b90
source_x86_64 = https://sites.google.com/site/mynotex/files/mynotex_1.4.1.0_amd64.deb
- md5sums_x86_64 = 657979d34ffe42af2da902894825e2cf
+ sha256sums_x86_64 = 0026f7182fd0f9c38b6c220a3ea82642d93241f78ba33360f0d66270bf9f8673
pkgname = mynotex
diff --git a/PKGBUILD b/PKGBUILD
index c86efa53b223..2aaab974710a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
# Contributor: saxonbeta <saxonbeta at gmail>
# Contributor: goten002 <goten002@gmail.com>
# Contributor: epinull
pkgname=mynotex
pkgver=1.4.1.0
-pkgrel=1
-pkgdesc="free note-taking and notes manager software for Linux"
-url="http://sites.google.com/site/mynotex"
+pkgrel=2
+pkgdesc="A free note-taking, document file and activity manager for GNU/Linux"
+url="https://sites.google.com/site/mynotex"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sqlite3' 'gtk2')
+optdepends=('gnupg: for notes encryption')
source_i686=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_i386.deb")
source_x86_64=("https://sites.google.com/site/${pkgname}/files/${pkgname}_${pkgver}_amd64.deb")
-md5sums_i686=('5ccdee9c57ef13a9e4902b97e86bc833')
-md5sums_x86_64=('657979d34ffe42af2da902894825e2cf')
-
+sha256sums_i686=('7a2b049d166609bec364e34ddf9899ff218c2fea410014f0af78472ee0fb4b90')
+sha256sums_x86_64=('0026f7182fd0f9c38b6c220a3ea82642d93241f78ba33360f0d66270bf9f8673')
package() {
tar -axf data.tar.xz -C "$pkgdir"
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/mynotex/mynotex" "${pkgdir}/usr/bin/mynotex"
}
-