summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD12
-rw-r--r--my-default.cnf31
3 files changed, 47 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8278628cd37..c39657ae9db6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 5 19:01:36 UTC 2017
+# Mon Apr 17 22:05:35 UTC 2017
pkgbase = mysql
pkgdesc = Fast SQL database server, community edition
- pkgver = 5.7.17
+ pkgver = 5.7.18
pkgrel = 1
url = https://www.mysql.com/products/community/
arch = i686
@@ -15,16 +15,18 @@ pkgbase = mysql
makedepends = libaio
makedepends = jemalloc
options = !libtool
- source = https://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-5.7.17.tar.gz
+ source = https://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-5.7.18.tar.gz
source = http://sourceforge.net/projects/boost/files/boost/1.59.0/boost_1_59_0.tar.gz
source = mysqld-post.sh
source = mysqld-tmpfile.conf
source = mysqld.service
- sha256sums = cebf23e858aee11e354c57d30de7a079754bdc2ef85eb684782458332a4b9651
+ source = my-default.cnf
+ sha256sums = 0b5d71ed608656cd8181d3bb0434d3e36bac192899038dbdddf5a7594aaea1a2
sha256sums = 47f11c8844e579d02691a607fbd32540104a9ac7a2534a8ddaef50daf502baac
sha256sums = 368f9fd2454d80eb32abb8f29f703d1cf9553353fb9e1ae4529c4b851cb8c5dd
sha256sums = 2af318c52ae0fe5428e8a9245d1b0fc3bc5ce153842d1563329ceb1edfa83ddd
sha256sums = 50212165bdb09855b97b15a917464ba34f82edf30a0c43f9a0c93a27071df556
+ sha256sums = 3cc3ba4149fb2f9e823601b9a414ff5b28a2a52f20bc68c74cc0505cf2d1832d
pkgname = mysql
pkgdesc = Fast SQL database server, community edition
@@ -34,7 +36,7 @@ pkgname = mysql
depends = jemalloc
depends = openssl
depends = zlib
- provides = mariadb=5.7.17
+ provides = mariadb=5.7.18
conflicts = mariadb
options = emptydirs
backup = etc/mysql/my.cnf
@@ -43,7 +45,7 @@ pkgname = libmysqlclient
pkgdesc = MySQL client libraries
depends = openssl
depends = zlib
- provides = libmariadbclient=5.7.17
+ provides = libmariadbclient=5.7.18
conflicts = libmariadbclient
pkgname = mysql-clients
@@ -52,6 +54,6 @@ pkgname = mysql-clients
depends = jemalloc
depends = openssl
depends = zlib
- provides = mariadb-clients=5.7.17
+ provides = mariadb-clients=5.7.18
conflicts = mariadb-clients
diff --git a/PKGBUILD b/PKGBUILD
index 4c2fc18bb244..3fb8c617f216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=('mysql' 'libmysqlclient' 'mysql-clients')
pkgbase=mysql
-pkgver=5.7.17
+pkgver=5.7.18
pkgrel=1
pkgdesc="Fast SQL database server, community edition"
arch=('i686' 'x86_64')
@@ -18,12 +18,14 @@ source=("https://dev.mysql.com/get/Downloads/MySQL-5.7/${pkgbase}-${pkgver}.tar.
"http://sourceforge.net/projects/boost/files/boost/${_boost_ver}/boost_${_boost_ver//./_}.tar.gz"
"mysqld-post.sh"
"mysqld-tmpfile.conf"
- "mysqld.service")
-sha256sums=('cebf23e858aee11e354c57d30de7a079754bdc2ef85eb684782458332a4b9651'
+ "mysqld.service"
+ "my-default.cnf")
+sha256sums=('0b5d71ed608656cd8181d3bb0434d3e36bac192899038dbdddf5a7594aaea1a2'
'47f11c8844e579d02691a607fbd32540104a9ac7a2534a8ddaef50daf502baac'
'368f9fd2454d80eb32abb8f29f703d1cf9553353fb9e1ae4529c4b851cb8c5dd'
'2af318c52ae0fe5428e8a9245d1b0fc3bc5ce153842d1563329ceb1edfa83ddd'
- '50212165bdb09855b97b15a917464ba34f82edf30a0c43f9a0c93a27071df556')
+ '50212165bdb09855b97b15a917464ba34f82edf30a0c43f9a0c93a27071df556'
+ '3cc3ba4149fb2f9e823601b9a414ff5b28a2a52f20bc68c74cc0505cf2d1832d')
build() {
rm -rf build
@@ -130,7 +132,7 @@ package_mysql(){
cd build
make DESTDIR="${pkgdir}" install
- install -m 644 -D "${pkgdir}/usr/share/mysql/my-default.cnf" "${pkgdir}/etc/mysql/my.cnf"
+ install -m 644 -D "${srcdir}/my-default.cnf" "${pkgdir}/etc/mysql/my.cnf"
install -m 755 -D "${srcdir}/mysqld-post.sh" "${pkgdir}/usr/bin/mysqld-post"
install -m 644 -D "${srcdir}/mysqld-tmpfile.conf" "${pkgdir}/usr/lib/tmpfiles.d/mysqld.conf"
install -m 755 -d "${pkgdir}/usr/lib/systemd/system"
diff --git a/my-default.cnf b/my-default.cnf
new file mode 100644
index 000000000000..caf77cbcd5de
--- /dev/null
+++ b/my-default.cnf
@@ -0,0 +1,31 @@
+# For advice on how to change settings please see
+# http://dev.mysql.com/doc/refman/5.7/en/server-configuration-defaults.html
+# *** DO NOT EDIT THIS FILE. It's a template which will be copied to the
+# *** default location during install, and will be replaced if you
+# *** upgrade to a newer version of MySQL.
+
+[mysqld]
+
+# Remove leading # and set to the amount of RAM for the most important data
+# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
+# innodb_buffer_pool_size = 128M
+
+# Remove leading # to turn on a very important data integrity option: logging
+# changes to the binary log between backups.
+# log_bin
+
+# These are commonly set, remove the # and set as required.
+# basedir = .....
+# datadir = .....
+# port = .....
+# server_id = .....
+# socket = .....
+
+# Remove leading # to set options mainly useful for reporting servers.
+# The server defaults are faster for transactions and fast SELECTs.
+# Adjust sizes as needed, experiment to find the optimal values.
+# join_buffer_size = 128M
+# sort_buffer_size = 2M
+# read_rnd_buffer_size = 2M
+
+sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES