summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--mythweb-php_7.2.patch21
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08149d9b09d2..e4b2e93aeb7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mythplugins
pkgver = 29.1
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = http://www.mythtv.org
arch = x86_64
@@ -32,9 +32,11 @@ pkgbase = mythplugins
source = mythtv-29.1.tar.gz::https://github.com/MythTV/mythtv/archive/v29.1.tar.gz
source = mythweb-29.1.tar.gz::https://github.com/MythTV/mythweb/archive/v29.1.tar.gz
source = cdparanoia.patch
+ source = mythweb-php_7.2.patch
sha256sums = e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e
sha256sums = 30583d7c077dbc732053d0ee7b13a46ab3ceaeb0aaa7c8e9744ef6ac959989e8
sha256sums = 004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c
+ sha256sums = 4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c
pkgname = mythplugins-mytharchive
pkgdesc = Create DVDs or archive recorded shows in MythTV
diff --git a/PKGBUILD b/PKGBUILD
index 89b5c3fd2460..6c81400ad356 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
pkgver=29.1
-pkgrel=3
+pkgrel=4
epoch=1
arch=('x86_64')
url="http://www.mythtv.org"
@@ -26,10 +26,12 @@ makedepends=('dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'libexif' 'mesa-libgl' "mythtv=
'python2-lxml' 'mysql-python' 'urlgrabber' 'python2-future')
source=("mythtv-$pkgver.tar.gz::https://github.com/MythTV/mythtv/archive/v$pkgver.tar.gz"
"mythweb-$pkgver.tar.gz::https://github.com/MythTV/mythweb/archive/v$pkgver.tar.gz"
- 'cdparanoia.patch')
+ 'cdparanoia.patch'
+ 'mythweb-php_7.2.patch') # can be removed for v29.2+
sha256sums=('e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e'
'30583d7c077dbc732053d0ee7b13a46ab3ceaeb0aaa7c8e9744ef6ac959989e8'
- '004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c')
+ '004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c'
+ '4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c')
prepare() {
cd "$srcdir/mythtv-$pkgver/$pkgbase"
@@ -38,6 +40,7 @@ prepare() {
patch -Np1 -i "$srcdir/cdparanoia.patch"
cd "$srcdir/mythweb-$pkgver"
+ patch -Np1 -i "$srcdir/mythweb-php_7.2.patch"
sed -re 's@/usr/local.*/usr/share@/usr/share@' -i 'mythweb.php'
}
diff --git a/mythweb-php_7.2.patch b/mythweb-php_7.2.patch
new file mode 100644
index 000000000000..a13493cddb01
--- /dev/null
+++ b/mythweb-php_7.2.patch
@@ -0,0 +1,21 @@
+Index: modules/tv/recorded.php
+===================================================================
+--- a/modules/tv/recorded.php (revision 6976c802b700dfed902c5173ca2d1080902508c6)
++++ b/modules/tv/recorded.php (revision 664dc1707ccf7be8b0b1d9eadf6366de8bbaa9c9)
+@@ -180,12 +180,12 @@
+ // GMP functions should work better with 64 bit numbers.
+ $size = gmp_mul('1024', $size);
+- define(disk_size, gmp_strval($size));
++ define('disk_size', gmp_strval($size));
+ $size = gmp_mul('1024', $used);
+- define(disk_used, gmp_strval($size));
++ define('disk_used', gmp_strval($size));
+ }
+ else {
+ // This is inaccurate, but it's the best we can get without GMP.
+- define(disk_size, ($size * 1024));
+- define(disk_used, ($used * 1024));
++ define('disk_size', ($size * 1024));
++ define('disk_used', ($used * 1024));
+ }
+