summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--libx264.patch25
3 files changed, 37 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4b2e93aeb7a..8b48fba421c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mythplugins
pkgver = 29.1
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = http://www.mythtv.org
arch = x86_64
@@ -33,10 +33,12 @@ pkgbase = mythplugins
source = mythweb-29.1.tar.gz::https://github.com/MythTV/mythweb/archive/v29.1.tar.gz
source = cdparanoia.patch
source = mythweb-php_7.2.patch
+ source = libx264.patch
sha256sums = e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e
sha256sums = 30583d7c077dbc732053d0ee7b13a46ab3ceaeb0aaa7c8e9744ef6ac959989e8
sha256sums = 004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c
sha256sums = 4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c
+ sha256sums = 810f26ac761c1a4c43d67637091d2765ccaf4be98036d8f33506b29d208ef344
pkgname = mythplugins-mytharchive
pkgdesc = Create DVDs or archive recorded shows in MythTV
diff --git a/PKGBUILD b/PKGBUILD
index 6c81400ad356..92773e67d48b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
pkgver=29.1
-pkgrel=4
+pkgrel=5
epoch=1
arch=('x86_64')
url="http://www.mythtv.org"
@@ -27,11 +27,13 @@ makedepends=('dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'libexif' 'mesa-libgl' "mythtv=
source=("mythtv-$pkgver.tar.gz::https://github.com/MythTV/mythtv/archive/v$pkgver.tar.gz"
"mythweb-$pkgver.tar.gz::https://github.com/MythTV/mythweb/archive/v$pkgver.tar.gz"
'cdparanoia.patch'
- 'mythweb-php_7.2.patch') # can be removed for v29.2+
+ 'mythweb-php_7.2.patch' # can be removed for v29.2+
+ 'libx264.patch') # can be removed for v29.2+
sha256sums=('e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e'
'30583d7c077dbc732053d0ee7b13a46ab3ceaeb0aaa7c8e9744ef6ac959989e8'
'004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c'
- '4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c')
+ '4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c'
+ '810f26ac761c1a4c43d67637091d2765ccaf4be98036d8f33506b29d208ef344')
prepare() {
cd "$srcdir/mythtv-$pkgver/$pkgbase"
@@ -39,6 +41,10 @@ prepare() {
find . -name '*.py' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
patch -Np1 -i "$srcdir/cdparanoia.patch"
+ #apply libx264.patch
+ cd "$srcdir/mythtv-$pkgver/mythtv"
+ patch -Np1 -i ../../libx264.patch
+
cd "$srcdir/mythweb-$pkgver"
patch -Np1 -i "$srcdir/mythweb-php_7.2.patch"
diff --git a/libx264.patch b/libx264.patch
new file mode 100644
index 000000000000..8401b2f9c26e
--- /dev/null
+++ b/libx264.patch
@@ -0,0 +1,25 @@
+--- a/external/FFmpeg/libavcodec/libx264.c
++++ b/external/FFmpeg/libavcodec/libx264.c
+@@ -279,7 +279,7 @@
+
+ x264_picture_init( &x4->pic );
+ x4->pic.img.i_csp = x4->params.i_csp;
+- if (x264_bit_depth > 8)
++ if (X264_BIT_DEPTH > 8)
+ x4->pic.img.i_csp |= X264_CSP_HIGH_DEPTH;
+ x4->pic.img.i_plane = avfmt2_num_planes(ctx->pix_fmt);
+
+@@ -889,11 +889,11 @@
+
+ static av_cold void X264_init_static(AVCodec *codec)
+ {
+- if (x264_bit_depth == 8)
++ if (X264_BIT_DEPTH == 8)
+ codec->pix_fmts = pix_fmts_8bit;
+- else if (x264_bit_depth == 9)
++ else if (X264_BIT_DEPTH == 9)
+ codec->pix_fmts = pix_fmts_9bit;
+- else if (x264_bit_depth == 10)
++ else if (X264_BIT_DEPTH == 10)
+ codec->pix_fmts = pix_fmts_10bit;
+ }