summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--n-ninja.install12
-rw-r--r--n-ninja.sh2
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6da07bd2e212
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = n-ninja
+ pkgdesc = Metanet's unique 2D puzzle/action platform game
+ pkgver = 2.0
+ pkgrel = 3
+ url = http://www.metanetsoftware.com/
+ install = n-ninja.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = flashplugin
+ source = n-ninja-2.0.tar::http://www.thewayoftheninja.org/Nv2-Linux.tar
+ source = n-ninja.sh
+ source = n-ninja.install
+ sha256sums = 3a6c0cb980a99a792eed6247e7afd27c235d62df759955107fca3043836c62d4
+ sha256sums = 0f02b3f3302ea91668a67a6cd2f5a0e0b0c6615f266cc23550390b4f6df6f9c1
+ sha256sums = da77d0239f3a4f10930fa200c3e2846bd461690edee0539081a0b8cc54b6e219
+
+pkgname = n-ninja
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96e31a1a09a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+# Contributor: Tim Yang <tdy@gmx.com>
+# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
+pkgname=n-ninja
+pkgver=2.0
+pkgrel=3
+pkgdesc="Metanet's unique 2D puzzle/action platform game"
+arch=('i686' 'x86_64')
+url="http://www.metanetsoftware.com/"
+license=('custom')
+install="${pkgname}.install"
+depends=('flashplugin')
+[ "$CARCH" == 'x86_64' ] && depends+=('lib32-flashplugin')
+source=("${pkgname}-${pkgver}.tar::http://www.thewayoftheninja.org/Nv2-Linux.tar"
+ "${pkgname}.sh"
+ "${install}")
+sha256sums=('3a6c0cb980a99a792eed6247e7afd27c235d62df759955107fca3043836c62d4'
+ '0f02b3f3302ea91668a67a6cd2f5a0e0b0c6615f266cc23550390b4f6df6f9c1'
+ 'da77d0239f3a4f10930fa200c3e2846bd461690edee0539081a0b8cc54b6e219')
+
+package() {
+ install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 Nv2-Linux.swf "${pkgdir}/usr/share/${pkgname}/${pkgname}.swf"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
+
diff --git a/n-ninja.install b/n-ninja.install
new file mode 100644
index 000000000000..6e81f719d642
--- /dev/null
+++ b/n-ninja.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo 'n-ninja uses the variable $BROWSER to open the game.'
+ echo "This variable must be set in order for the game to run."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/n-ninja.sh b/n-ninja.sh
new file mode 100644
index 000000000000..7dd844b5c1e1
--- /dev/null
+++ b/n-ninja.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/bash
+"$BROWSER" /usr/share/n-ninja/n-ninja.swf