summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
-rwxr-xr-xbuild.sh8
3 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c74aee1a390..cf1e2c95d711 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = naiveproxy-git
makedepends = gn
makedepends = unzip
makedepends = python2
+ makedepends = llvm
depends = nspr
depends = nss
optdepends = ccache: Speed up compilation
@@ -20,7 +21,7 @@ pkgbase = naiveproxy-git
source = git+https://github.com/klzgrad/naiveproxy.git
source = build.sh
md5sums = SKIP
- md5sums = 39e64c1967684ff2966eedc2f2d8decf
+ md5sums = 97aa54a097b10d2de82e026ba927e9e8
pkgname = naiveproxy-git
diff --git a/PKGBUILD b/PKGBUILD
index 3c24beea18a1..04f551317f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,11 +11,11 @@ license=('BSD')
depends=('nspr' 'nss')
source=('git+https://github.com/klzgrad/naiveproxy.git'
'build.sh')
-makedepends=("clang" "lld" "gn" "unzip" "python2")
+makedepends=("clang" "lld" "gn" "unzip" "python2" "llvm")
optdepends=("ccache: Speed up compilation")
backup=(etc/naiveproxy/config.json)
md5sums=('SKIP'
- '39e64c1967684ff2966eedc2f2d8decf')
+ '97aa54a097b10d2de82e026ba927e9e8')
provides=('naiveproxy')
conflicts=('naiveproxy' 'naiveproxy-bin')
@@ -26,7 +26,7 @@ pkgver(){
build(){
cd ${srcdir}/${_pkgname}/src
- env EXTRA_FLAGS='clang_base_path="" clang_use_chrome_plugins=false clang_use_default_sample_profile=false' ../../build.sh
+ ../../build.sh
}
package(){
diff --git a/build.sh b/build.sh
index 5e9d318e87bd..63fa44ffdaff 100755
--- a/build.sh
+++ b/build.sh
@@ -64,6 +64,14 @@ if [ "$(uname)" = Linux ]; then
ozone_platform_headless=true'
fi
+# use system clang
+# disable clang plugins
+# build without afdo.prof
+flags="$flags"'
+ clang_base_path=""
+ clang_use_chrome_plugins=false
+ clang_use_default_sample_profile=false'
+
rm -rf "./$out"
mkdir -p out