summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
-rw-r--r--fix-build-for-boost-1.76.patch32
-rw-r--r--fix-build-for-gcc11.patch24
-rw-r--r--provide-boost.patch13
5 files changed, 52 insertions, 81 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97b1b464a8d8..41c83da40ca3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nanocurrency
pkgdesc = Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
- pkgver = 22.1
+ pkgver = 24.0
pkgrel = 2
url = https://nano.org/
install = install
@@ -9,8 +9,6 @@ pkgbase = nanocurrency
license = BSD 2-clause
makedepends = cmake
depends = qt5-base
- depends = boost>=1.69.0
- depends = boost-libs>=1.69.0
provides = raiblocks
provides = nanocurrency
conflicts = raiblocks
@@ -20,23 +18,25 @@ pkgbase = nanocurrency
source = nanowallet.desktop
source = nanowallet128.png
source = nano-node.service
- source = fix-build-for-gcc11.patch
- source = fix-build-for-boost-1.76.patch
- source = git+https://github.com/nanocurrency/nano-node.git#tag=V22.1
+ source = provide-boost.patch
+ source = boost_1_75_0.tar.bz2::https://sourceforge.net/projects/boost/files/boost/1.75.0/boost_1_75_0.tar.bz2/download
+ source = git+https://github.com/nanocurrency/nano-node.git#tag=V24.0
source = git+https://github.com/weidai11/cryptopp.git
- source = git+https://github.com/nanocurrency/lmdb.git
+ source = git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_23
source = git+https://github.com/miniupnp/miniupnp.git
source = git+https://github.com/nanocurrency/phc-winner-argon2.git
source = git+https://github.com/google/flatbuffers.git
- source = git+https://github.com/nanocurrency/rocksdb.git
+ source = git+https://github.com/nanocurrency/rocksdb.git#branch=6.13.3
source = git+https://github.com/cryptocode/cpptoml.git
source = git+https://github.com/google/googletest.git
source = git+https://github.com/nanocurrency/nano-pow-server.git
+ source = git+https://github.com/nanocurrency/diskhash.git
sha256sums = 6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91
sha256sums = 27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e
sha256sums = c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35
- sha256sums = fff6e6ab537c33e522a6c91d1d917c8298c3c2a92e291b343663793bcf60336f
- sha256sums = 98ec1f48ecdcf5c6270ead3f50eae427b33a68eebcdf2c7432d91fabd12f1b81
+ sha256sums = dbfe2a1774c2c5c2567cbfa9731c431f01076b62f7ea9b3657c875d1dbe2dada
+ sha256sums = 953db31e016db7bb207f11432bef7df100516eeb746843fa0486a222e3fd49cb
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8ce9c56b5362..acec8af5c0a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=nanocurrency
-pkgver=22.1
+pkgver=24.0
_tag="V$pkgver"
pkgrel=2
pkgdesc="Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
@@ -7,7 +7,7 @@ arch=('i686' 'x86_64')
url="https://nano.org/"
license=('BSD 2-clause')
makedepends=('cmake')
-depends=('qt5-base' 'boost>=1.69.0' 'boost-libs>=1.69.0')
+depends=('qt5-base')
provides=(raiblocks nanocurrency)
conflicts=("raiblocks" "raiblocks-git" "raiblocks-node-git" "nanocurrency-node-git")
install=install
@@ -15,25 +15,27 @@ install=install
source=(nanowallet.desktop
nanowallet128.png
nano-node.service
- fix-build-for-gcc11.patch
- fix-build-for-boost-1.76.patch
+ provide-boost.patch
+ "boost_1_75_0.tar.bz2::https://sourceforge.net/projects/boost/files/boost/1.75.0/boost_1_75_0.tar.bz2/download"
"git+https://github.com/nanocurrency/nano-node.git#tag=${_tag}"
git+https://github.com/weidai11/cryptopp.git
- git+https://github.com/nanocurrency/lmdb.git
+ "git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_23"
git+https://github.com/miniupnp/miniupnp.git
git+https://github.com/nanocurrency/phc-winner-argon2.git
- git+https://github.com/google/flatbuffers.git
- git+https://github.com/nanocurrency/rocksdb.git
+ "git+https://github.com/google/flatbuffers.git"
+ "git+https://github.com/nanocurrency/rocksdb.git#branch=6.13.3"
git+https://github.com/cryptocode/cpptoml.git
git+https://github.com/google/googletest.git
git+https://github.com/nanocurrency/nano-pow-server.git
+ git+https://github.com/nanocurrency/diskhash.git
)
sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
'27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e'
'c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35'
- 'fff6e6ab537c33e522a6c91d1d917c8298c3c2a92e291b343663793bcf60336f'
- '98ec1f48ecdcf5c6270ead3f50eae427b33a68eebcdf2c7432d91fabd12f1b81'
+ 'dbfe2a1774c2c5c2567cbfa9731c431f01076b62f7ea9b3657c875d1dbe2dada'
+ '953db31e016db7bb207f11432bef7df100516eeb746843fa0486a222e3fd49cb'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -45,6 +47,7 @@ sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
'SKIP'
'SKIP')
+
_submodule_config() {
submodule_name=$1
submodule_path=$2
@@ -69,12 +72,16 @@ prepare() {
_submodule_config cpptoml
_submodule_config googletest
_submodule_config nano-pow-server
+ _submodule_config diskhash
git submodule init
- git submodule update --recursive
+ git -c protocol.file.allow=always submodule update --recursive
- patch --forward -p1 -i $srcdir/fix-build-for-gcc11.patch
- patch --forward -p1 -i $srcdir/fix-build-for-boost-1.76.patch
+ cd "${srcdir}/nano-node"
+ patch --forward -p0 -i $srcdir/provide-boost.patch
+ ln -sf "$srcdir/boost_1_75_0.tar.bz2" ./
+ ln -sf "$srcdir/boost_1_75_0" ./
+# patch --forward -p1 -i $srcdir/fix-build-for-boost-1.76.patch
}
build() {
@@ -88,7 +95,7 @@ build() {
tmp_path=${tmp_path#:}
PATH=$tmp_path
- _flags="-DNANO_GUI=ON -DFAIL_ON_WARNINGS=OFF"
+ _flags="-DNANO_GUI=ON -DFAIL_ON_WARNINGS=OFF -DFLATBUFFERS_STRICT_MODE=OFF -DCMAKE_CXX_FLAGS=\"-Wno-error\""
if grep -q avx2 /proc/cpuinfo; then
echo "using AVX2 optimizations"
@@ -106,9 +113,16 @@ build() {
_cores=$(grep processor /proc/cpuinfo | wc -l)
#_cores=1
+
+ export BOOST_ROOT="$srcdir/boost_build"
+ echo "build boost..."
+ pushd "$srcdir/nano-node" >/dev/null
+ bash util/build_prep/bootstrap_boost.sh -j $_cores -B 1.75 -m
+ popd >/dev/null
+
PATH=$PATH cmake $_flags ./
- make -j${_cores} nano_wallet
- make -j${_cores} nano_node
+ make -j${_cores} VERBOSE=1 nano_wallet
+ make -j${_cores} VERBOSE=1 nano_node
}
package() {
diff --git a/fix-build-for-boost-1.76.patch b/fix-build-for-boost-1.76.patch
deleted file mode 100644
index 410993d26bc3..000000000000
--- a/fix-build-for-boost-1.76.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From cb8abd16b5e65f5b6410d146e38949823118867a Mon Sep 17 00:00:00 2001
-From: Leo P <junk@slact.net>
-Date: Mon, 30 Aug 2021 22:04:06 -0400
-Subject: [PATCH] fix failing build with boost >= 1.76
-
----
- nano/node/common.hpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/nano/node/common.hpp b/nano/node/common.hpp
-index 4672b778..d7e77e4f 100644
---- a/nano/node/common.hpp
-+++ b/nano/node/common.hpp
-@@ -112,6 +112,7 @@ struct hash<::nano::tcp_endpoint>
- return ehash (endpoint_a);
- }
- };
-+#ifndef BOOST_ASIO_HAS_STD_HASH
- template <>
- struct hash<boost::asio::ip::address>
- {
-@@ -121,6 +122,7 @@ struct hash<boost::asio::ip::address>
- return ihash (ip_a);
- }
- };
-+#endif
- }
- namespace boost
- {
---
-2.33.0
-
diff --git a/fix-build-for-gcc11.patch b/fix-build-for-gcc11.patch
deleted file mode 100644
index fac738160a5c..000000000000
--- a/fix-build-for-gcc11.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 1b2bbf7b5f2ff585796a8a9644d04fe7beb5777a Mon Sep 17 00:00:00 2001
-From: Leo P <junk@slact.net>
-Date: Mon, 30 Aug 2021 21:56:30 -0400
-Subject: [PATCH] fix failure to build with GCC11
-
----
- nano/lib/threading.hpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/nano/lib/threading.hpp b/nano/lib/threading.hpp
-index f6ab4e18..5f09666f 100644
---- a/nano/lib/threading.hpp
-+++ b/nano/lib/threading.hpp
-@@ -5,6 +5,7 @@
- #include <nano/lib/utility.hpp>
-
- #include <boost/thread/thread.hpp>
-+#include <thread>
-
- namespace nano
- {
---
-2.33.0
-
diff --git a/provide-boost.patch b/provide-boost.patch
new file mode 100644
index 000000000000..874046dfa6ae
--- /dev/null
+++ b/provide-boost.patch
@@ -0,0 +1,13 @@
+--- util/build_prep/bootstrap_boost.sh 2023-03-09 00:21:53.361480936 -0500
++++ util/build_prep/bootstrap_boost.sh.new 2023-03-09 00:22:05.781957983 -0500
+@@ -136,8 +136,8 @@
+ buildArgs+=(linkflags="${buildLDArgs[*]}")
+ fi
+
+-rm -rf "${BOOST_BASENAME}"
+-tar xf "${BOOST_ARCHIVE}"
++#rm -rf "${BOOST_BASENAME}"
++#tar xf "${BOOST_ARCHIVE}"
+
+ pushd "${BOOST_BASENAME}"
+ ./bootstrap.sh "${bootstrapArgs[@]}"