summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b726269893ab..6cadda650948 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
# Generated by mksrcinfo v8
-# Fri Aug 24 14:34:32 UTC 2018
+# Fri Aug 24 14:52:34 UTC 2018
pkgbase = nawk-git
pkgdesc = The version of awk described in "The AWK Programming Language".
pkgver = 20180823.r9.0f4e1ba
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/onetrueawk/awk
arch = i686
arch = x86_64
license = MIT
makedepends = git
depends = glibc
+ provides = nawk
conflicts = nawk
options = !makeflags
source = nawk-git::git+https://github.com/onetrueawk/awk
diff --git a/PKGBUILD b/PKGBUILD
index 5828d6665986..b81627a3653c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: aksr <aksr at t-com dot me>
pkgname=nawk-git
pkgver=20180823.r9.0f4e1ba
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc='The version of awk described in "The AWK Programming Language".'
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ depends=(glibc)
makedepends=(git)
optdepends=()
checkdepends=()
-provides=()
+provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
replaces=()
backup=()
@@ -42,6 +42,11 @@ build() {
make "CPPFLAGS=-DHAS_ISBLANK $CPPFLAGS" "LDFLAGS=$LDFLAGS" "CFLAGS=$CFLAGS"
}
+check() {
+ cd "$srcdir/$pkgname"
+ ./REGRESS
+}
+
package() {
cd "$srcdir/$pkgname"
install -Dm755 a.out "$pkgdir/usr/bin/nawk"