summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d05f51a789c..3cdf8320c251 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = nbfc-linux
pkgdesc = Lightweight C port of NoteBook FanControl (no Mono required)
- pkgver = 0.1.5
- pkgrel = 2
+ pkgver = 0.1.12
+ pkgrel = 1
url = https://github.com/nbfc-linux/nbfc-linux
arch = i686
arch = x86_64
license = GPL3
- optdepends = dmidecode: for getting recommended notebook configurations
provides = nbfc
conflicts = nbfc
- source = nbfc-linux-0.1.5.tar.gz::https://github.com/nbfc-linux/nbfc-linux/archive/refs/tags/0.1.5.tar.gz
- sha512sums = 3acfa0cfa7e72e2dd1a496d6285b79b8bf1fc272b8094c87c656ce4f0ca5a60f308e6966f3374e1af2cd2f8bf32482abd7f215550f807ba8940acd4d44bdff56
+ source = nbfc-linux-0.1.12.tar.gz::https://github.com/nbfc-linux/nbfc-linux/archive/refs/tags/0.1.12.tar.gz
+ sha512sums = 29209e71a2e4e21139195ce7889a11f84d1326c2ec344a584f21ef3f256bd05566983fc323a743f584bb670e22bc3a17da999a5eb0d9033a0b6e5ea021707723
pkgname = nbfc-linux
diff --git a/PKGBUILD b/PKGBUILD
index f294106ebefe..a54af7c8b7fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,26 @@
# Contributor: Benjamin Abendroth <braph93@gmx.de>
pkgname=nbfc-linux
-pkgver=0.1.5
-pkgrel=2
+pkgver=0.1.12
+pkgrel=1
pkgdesc="Lightweight C port of NoteBook FanControl (no Mono required)"
arch=('i686' 'x86_64')
url="https://github.com/nbfc-linux/nbfc-linux"
-optdepends=('dmidecode: for getting recommended notebook configurations')
license=('GPL3')
conflicts=('nbfc')
provides=('nbfc')
source=("$pkgname-$pkgver.tar.gz::https://github.com/nbfc-linux/nbfc-linux/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('3acfa0cfa7e72e2dd1a496d6285b79b8bf1fc272b8094c87c656ce4f0ca5a60f308e6966f3374e1af2cd2f8bf32482abd7f215550f807ba8940acd4d44bdff56')
+sha512sums=('29209e71a2e4e21139195ce7889a11f84d1326c2ec344a584f21ef3f256bd05566983fc323a743f584bb670e22bc3a17da999a5eb0d9033a0b6e5ea021707723')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make
+ make PREFIX=/usr confdir=/etc
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make PREFIX=/usr confdir=/etc DESTDIR="${pkgdir}" install
}
# vim:set ts=2 sw=2 et: