summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xPKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 58bf6ba9772e..513a4166676e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ pkgver()
{
cd ${srcdir}/${_pkgname}/
version=$(git describe --tags --abbrev=0)
- printf "%s" ${version:1} | sed "s/\([^-]*-g\)/r\1/;s/-/./g"
+ printf "%s" ${version} | sed "s/^v//;s/-/_/g;s/\//./g"
}
build()
@@ -52,7 +52,7 @@ package()
# Modify run.sh to state the absolute path of the .csproj.
echo -e "#!/bin/bash
- dotnet run --no-launch-profile --no-build -c Release -p \"/usr/lib/${_pkgname}/NBXplorer/NBXplorer.csproj\" -- $@" > ${srcdir}/${_pkgname}/run.sh
+ dotnet run --no-launch-profile --no-build -c Release -p \"/usr/lib/${_pkgname}/NBXplorer/NBXplorer.csproj\" -- ${@}" > ${srcdir}/${_pkgname}/run.sh
# Create nbxplorer-start.sh.
echo -e "#!/bin/bash
@@ -62,8 +62,8 @@ package()
echo -e "#!/bin/bash
tmux kill-session -t ${_pkgname_lc}" > ${srcdir}/${_pkgname}/${_pkgname_lc}-stop.sh
- # Put the installation at the right place.
- cp -r ${srcdir}/${_pkgname}/ ${pkgdir}/usr/lib/
+ # Install the software.
+ install -Ddm755 ${srcdir}/${_pkgname}/ ${pkgdir}/usr/lib/
# Symlinking the scripts.
ln -sfrT ${pkgdir}/usr/lib/${_pkgname}/run.sh ${pkgdir}/usr/bin/${_pkgname_lc}