summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--ncbi-vdb-2.6.2.patch16
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a6be7b4ccdc..69a577863e54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ncbi-vdb
pkgdesc = The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives.
- pkgver = 2.5.8
+ pkgver = 2.6.2
pkgrel = 1
url = https://github.com/ncbi/ncbi-vdb
arch = x86_64
@@ -9,8 +9,10 @@ pkgbase = ncbi-vdb
depends = ngs
depends = hdf5
provides = ncbi-vdb
- source = https://github.com/ncbi/ncbi-vdb/archive/2.5.8.tar.gz
- sha256sums = 7a0ccc3434220e5288a016e4a9e24d4a1deae2a7d5de594fc94b2442172b3229
+ source = https://github.com/ncbi/ncbi-vdb/archive/2.6.2.tar.gz
+ source = ncbi-vdb-2.6.2.patch
+ sha256sums = c310edacd1a4f98a5cfab702f3eede98977ef64831f002fddd7728ed7e2034f4
+ sha256sums = 4062cc8018e26192eaaff6d27205a3854e223f2e9c75b2d935a283bf85e1f99c
pkgname = ncbi-vdb
diff --git a/PKGBUILD b/PKGBUILD
index dbbd5eb9b784..b62f10da51aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Aaron Baker <aa{last name}99{at}gmail{dt}org>
pkgname=ncbi-vdb
-pkgver=2.5.8
+pkgver=2.6.2
pkgrel=1
pkgdesc="The SRA Toolkit and SDK from NCBI is a collection of tools and libraries for using data in the INSDC Sequence Read Archives."
arch=('x86_64')
@@ -10,11 +10,13 @@ url="https://github.com/ncbi/ncbi-vdb"
depends=('libxml2' 'ngs' 'hdf5')
provides=('ncbi-vdb')
license=('custom:PublicDomain')
-source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz")
-sha256sums=('7a0ccc3434220e5288a016e4a9e24d4a1deae2a7d5de594fc94b2442172b3229')
+source=("https://github.com/ncbi/ncbi-vdb/archive/$pkgver.tar.gz" "$pkgname-$pkgver.patch")
+sha256sums=('c310edacd1a4f98a5cfab702f3eede98977ef64831f002fddd7728ed7e2034f4' '4062cc8018e26192eaaff6d27205a3854e223f2e9c75b2d935a283bf85e1f99c')
prepare(){
cd "${pkgname}-${pkgver}"
+ # stop NCBI root checks for great good
+ patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
}
build(){
diff --git a/ncbi-vdb-2.6.2.patch b/ncbi-vdb-2.6.2.patch
new file mode 100644
index 000000000000..7ed02c4d14e6
--- /dev/null
+++ b/ncbi-vdb-2.6.2.patch
@@ -0,0 +1,16 @@
+diff -aur ncbi-vdb-2.6.2/build/Makefile.install ncbi-vdb-2.6.2-patch/build/Makefile.install
+--- ncbi-vdb-2.6.2/build/Makefile.install 2016-04-21 18:52:55.000000000 +0000
++++ ncbi-vdb-2.6.2-patch/build/Makefile.install 2016-05-06 19:53:56.615385102 +0000
+@@ -66,12 +66,6 @@
+ PROFILE_FILE = $(ROOT)/etc/profile.d/ncbi-vdb
+ KONFIG_DIR = $(ROOT)/etc/ncbi/
+
+-ifeq (linux, $(OS))
+- ifeq (0, $(shell id -u))
+- LINUX_ROOT = true
+- endif
+-endif
+-
+ install: copylibs copyincludes
+ ifeq (true, $(LINUX_ROOT))
+ @ # install symlink to includes