summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47038b5cbdfe..cd319609aaa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = ncmdump-git
pkgdesc = netease cloud music copyright protection file dump
- pkgver = r20.ee3bdb4
+ pkgver = r9.131e769
pkgrel = 1
- url = https://github.com/anonymous5l/ncmdump
- arch = i686
- arch = x86_64
+ epoch = 1
+ url = https://github.com/taurusxin/ncmdump
+ arch = any
license = unknown
makedepends = git
depends = taglib
provides = ncmdump
conflicts = ncmdump
- source = ncmdump::git+https://github.com/anonymous5l/ncmdump
- md5sums = SKIP
+ source = ncmdump::git+https://github.com/taurusxin/ncmdump
+ sha256sums = SKIP
pkgname = ncmdump-git
-
diff --git a/.gitignore b/.gitignore
index 9344f7cdf15d..cf662c466be2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
*.sign
/src
/pkg
+ncmdump
diff --git a/PKGBUILD b/PKGBUILD
index 0ad6f5f646da..a66c5c285bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=ncmdump-git
_basename="${pkgname%-git}"
-pkgver=r20.ee3bdb4
+pkgver=r9.131e769
pkgrel=1
+epoch=1
pkgdesc='netease cloud music copyright protection file dump'
-arch=('i686' 'x86_64')
-url='https://github.com/anonymous5l/ncmdump'
+arch=('any')
+url='https://github.com/taurusxin/ncmdump'
conflicts=("$_basename")
provides=("$_basename")
license=('unknown')
depends=('taglib')
makedepends=('git')
-source=("$_basename"::'git+https://github.com/anonymous5l/ncmdump')
-md5sums=('SKIP')
+source=("$_basename"::'git+https://github.com/taurusxin/ncmdump')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_basename"
@@ -22,7 +23,7 @@ pkgver() {
build() {
cd "$srcdir/$_basename"
- make
+ make linux
}
package() {