summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--neobundle.install21
-rw-r--r--neobundle.vimrc30
4 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0da807490018
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neobundle-git
+ pkgdesc = Ultimate Vim plugin manager inspired by Vundle
+ pkgver = 3.0.32.g2f94664
+ pkgrel = 1
+ url = https://github.com/Shougo/neobundle.vim
+ install = neobundle.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vim>=7.2.051
+ source = neobundle-git::git+https://github.com/Shougo/neobundle.vim.git
+ source = neobundle.vimrc
+ sha512sums = SKIP
+ sha512sums = 0f213143dca741957c9873fe881666b86b66fa285db6e3fdd85f4121596798169de6201b3660b1960602a0e6f2bc54ddb98a4ff42041e7ce59b08bd75190ec01
+
+pkgname = neobundle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc47d255ed48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: oozyslug <oozyslug at gmail dot com>
+# Contributor: oozyslug <oozyslug at gmail dot com>
+
+pkgname=neobundle-git
+pkgver=3.0.32.g2f94664
+pkgrel=1
+pkgdesc="Ultimate Vim plugin manager inspired by Vundle"
+arch=('any')
+url="https://github.com/Shougo/neobundle.vim"
+license=('GPL')
+depends=('vim>=7.2.051')
+makedepends=('git')
+install=neobundle.install
+source=('neobundle-git::git+https://github.com/Shougo/neobundle.vim.git'
+ 'neobundle.vimrc'
+ )
+sha512sums=('SKIP'
+ '0f213143dca741957c9873fe881666b86b66fa285db6e3fdd85f4121596798169de6201b3660b1960602a0e6f2bc54ddb98a4ff42041e7ce59b08bd75190ec01'
+ )
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/^ver\.//;s/-/./g'
+
+}
+package() {
+ cd "$srcdir/$pkgname"
+
+ vimpath="${pkgdir}/usr/share/vim/vimfiles/"
+
+ mkdir -p ${vimpath}/doc
+ cp -R doc ${vimpath}
+
+ mkdir -p ${vimpath}/autoload
+ cp -R autoload ${vimpath}
+
+ install -Dm644 LICENSE-MIT.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 README.md ${pkgdir}/usr/share/doc/${pkgname}/README
+ install -Dm644 ${srcdir}/neobundle.vimrc ${pkgdir}/usr/share/neobundle/vimrc.sample
+}
+
diff --git a/neobundle.install b/neobundle.install
new file mode 100644
index 000000000000..9d4248671d92
--- /dev/null
+++ b/neobundle.install
@@ -0,0 +1,21 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+ echo "To use neobundle, please check the file in /usr/share/neobundle/vimrc.sample"
+ echo "and update your ~/.vimrc file, accordingly"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+ echo "Please remember to remove neobundles from your ~/.vimrc file"
+ echo "and from your ~/.vim directory!"
+}
diff --git a/neobundle.vimrc b/neobundle.vimrc
new file mode 100644
index 000000000000..b41536c19e94
--- /dev/null
+++ b/neobundle.vimrc
@@ -0,0 +1,30 @@
+"Note: Skip initialization for vim-tiny or vim-small.
+if 0 | endif
+
+if has('vim_starting')
+ if &compatible
+ set nocompatible " Be iMproved
+ endif
+endif
+
+" Required:
+call neobundle#begin(expand('~/.vim/bundle/'))
+
+ " My Bundles here:
+ " Refer to |:NeoBundle-examples|.
+ " Note: You don't set neobundle setting in .gvimrc!
+ " Original repos on github
+ NeoBundle 'tpope/vim-fugitive'
+
+ " vim-scripts repos
+ NeoBundle 'FuzzyFinder'
+
+call neobundle#end()
+
+" Required:
+filetype plugin indent on
+
+" If there are uninstalled bundles found on startup,
+" this will conveniently prompt you to install them.
+"NeoBundleCheck
+