summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--io-curses.patch13
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9ae3518f687..8565677c8ebb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neoleo-git
pkgdesc = Lightweight curses spreadsheet based on GNU oleo
- pkgver = 10.0.r152.gb0d78af
+ pkgver = 11.0.r9.g33b25b4
pkgrel = 1
url = https://github.com/blippy/neoleo
arch = i686
@@ -12,7 +12,7 @@ pkgbase = neoleo-git
conflicts = neoleo
options = !makeflags
source = git+https://github.com/blippy/neoleo.git
+ source = io-curses.patch
sha256sums = SKIP
pkgname = neoleo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e31e1d95869e..05043126d9ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=neoleo-git
-pkgver=10.0.r152.gb0d78af
+pkgver=11.0.r9.g33b25b4
pkgrel=1
pkgdesc="Lightweight curses spreadsheet based on GNU oleo"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ provides=(${pkgname%-git})
license=('GPL')
depends=('ncurses')
makedepends=('git')
-source=("git+$url.git")
+source=("git+$url.git" io-curses.patch)
options=('!makeflags')
sha256sums=('SKIP')
@@ -20,10 +20,11 @@ pkgver() {
cd ${pkgname%-git}
git describe --tags | sed 's+-+.r+' |tr - . | cut -c2-
}
+
build() {
cd ${pkgname%-git}
autoreconf -iv
- LIBS+="-lstdc++fs" ./configure --prefix=/usr
+ LIBS+="-lstdc++fs" ./configure --prefix=/usr
make
}
diff --git a/io-curses.patch b/io-curses.patch
new file mode 100644
index 000000000000..ffff789ec1ec
--- /dev/null
+++ b/io-curses.patch
@@ -0,0 +1,13 @@
+diff --git a/src/io-curses.cc b/src/io-curses.cc
+index e808775..d0ec3a7 100644
+--- a/src/io-curses.cc
++++ b/src/io-curses.cc
+@@ -538,7 +538,7 @@ _io_repaint (void)
+ if (win->lh_wid)
+ {
+ move (win->win_down - 1, win->win_over - win->lh_wid);
+- printw ("#%*d ", win->lh_wid - 2, 1 + win - wins);
++ printw ("#%*ld ", win->lh_wid - 2, 1 + win - wins);
+ if (win->flags & WIN_EDGE_REV)
+ s_display.cdstandout();
+ cc = win->screen.lc;