summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--io-curses.patch13
3 files changed, 6 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdd78d117af0..adc05da5b852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neoleo-git
pkgdesc = Lightweight curses spreadsheet based on GNU oleo
- pkgver = 11.0.r9.g33b25b4
- pkgrel = 3
+ pkgver = 12.0
+ pkgrel = 1
url = https://github.com/blippy/neoleo
arch = i686
arch = x86_64
@@ -12,8 +12,6 @@ pkgbase = neoleo-git
conflicts = neoleo
options = !makeflags
source = git+https://github.com/blippy/neoleo.git
- source = io-curses.patch
sha256sums = SKIP
- sha256sums = b1c89e5b4f9eaf887c8bdb9d0a54d2b150869c71a6018fae700f119ca43a0983
pkgname = neoleo-git
diff --git a/PKGBUILD b/PKGBUILD
index 1a53e38f3584..befe9722bcb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=neoleo-git
-pkgver=11.0.r9.g33b25b4
-pkgrel=3
+pkgver=12.0
+pkgrel=1
pkgdesc="Lightweight curses spreadsheet based on GNU oleo"
arch=('i686' 'x86_64')
url="https://github.com/blippy/neoleo"
@@ -12,21 +12,15 @@ provides=(${pkgname%-git})
license=('GPL')
depends=('ncurses')
makedepends=('git')
-source=("git+$url.git" io-curses.patch)
+source=("git+$url.git")
options=('!makeflags')
-sha256sums=('SKIP'
- 'b1c89e5b4f9eaf887c8bdb9d0a54d2b150869c71a6018fae700f119ca43a0983')
+sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
git describe --tags | sed 's+-+.r+' |tr - . | cut -c2-
}
-prepare() {
- cd ${pkgname%-git}
- git apply "$srcdir"/io-curses.patch
-}
-
build() {
cd ${pkgname%-git}
autoreconf -iv
diff --git a/io-curses.patch b/io-curses.patch
deleted file mode 100644
index ffff789ec1ec..000000000000
--- a/io-curses.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/io-curses.cc b/src/io-curses.cc
-index e808775..d0ec3a7 100644
---- a/src/io-curses.cc
-+++ b/src/io-curses.cc
-@@ -538,7 +538,7 @@ _io_repaint (void)
- if (win->lh_wid)
- {
- move (win->win_down - 1, win->win_over - win->lh_wid);
-- printw ("#%*d ", win->lh_wid - 2, 1 + win - wins);
-+ printw ("#%*ld ", win->lh_wid - 2, 1 + win - wins);
- if (win->flags & WIN_EDGE_REV)
- s_display.cdstandout();
- cc = win->screen.lc;