summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD53
-rw-r--r--default-ca-certificates.patch12
3 files changed, 74 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a42592421dc5..0ac1233d8dfb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,42 @@
-# Generated by mksrcinfo v8
-# Sat Feb 3 08:22:20 UTC 2018
pkgbase = neomutt-git
pkgdesc = A version of mutt with added features - development branch
- pkgver = 20171215.r144.gb7da81ad
- pkgrel = 2
+ pkgver = 20220429.r226.gecc8075f9
+ pkgrel = 1
url = http://www.neomutt.org/
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL
makedepends = git
makedepends = gnupg
makedepends = libxslt
makedepends = docbook-xsl
- makedepends = lynx
+ makedepends = w3m
+ depends = glibc
+ depends = gpgme
+ depends = lua53
depends = notmuch-runtime
- depends = lua
+ depends = krb5
+ depends = gnutls
+ depends = sqlite
+ depends = libsasl
+ depends = ncurses
+ depends = libidn2
+ depends = lmdb
+ depends = gdbm
+ depends = kyotocabinet
+ depends = lz4
+ depends = zlib
+ depends = zstd
+ depends = db
optdepends = python: keybase.py
+ optdepends = perl: smime_keys
+ optdepends = ca-certificates: default CA certificates
provides = neomutt
conflicts = neomutt
- source = git+https://github.com/neomutt/neomutt.git#branch=master
+ source = git+https://github.com/neomutt/neomutt.git#branch=main
+ source = default-ca-certificates.patch
sha256sums = SKIP
+ sha256sums = 571716b8979e9b43328416c3c56eff228b6c58355d7c080b8987ea89c6360776
pkgname = neomutt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 134cca4c9cb1..2104c814dd03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,64 @@
-# Maintainer: Alad Wenter <alad@mailbox.org>
+# Maintainer: A Farzat <a@farzat.xyz>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Alad Wenter <alad@mailbox.org>
# Contributor: Sean Haugh <seanphaugh@gmail.com>
# Contributor: Chris Salzberg <chris@dejimata.com>
_pkgname=neomutt
pkgname=neomutt-git
-pkgver=20171215.r144.gb7da81ad
-pkgrel=2
+pkgver=20220429.r226.gecc8075f9
+pkgrel=1
pkgdesc='A version of mutt with added features - development branch'
url='http://www.neomutt.org/'
license=('GPL')
-source=('git+https://github.com/neomutt/neomutt.git#branch=master')
-sha256sums=('SKIP')
-arch=('i686' 'x86_64')
-depends=('notmuch-runtime' 'lua')
-optdepends=('python: keybase.py')
-makedepends=('git' 'gnupg' 'libxslt' 'docbook-xsl' 'lynx')
+arch=('i686' 'x86_64' 'aarch64')
+depends=('glibc' 'gpgme' 'lua53' 'notmuch-runtime' 'krb5' 'gnutls' 'sqlite'
+ 'libsasl' 'ncurses' 'libidn2' 'lmdb' 'gdbm' 'kyotocabinet'
+ 'lz4' 'zlib' 'zstd' 'db')
+optdepends=('python: keybase.py'
+ 'perl: smime_keys'
+ 'ca-certificates: default CA certificates')
+makedepends=('git' 'gnupg' 'libxslt' 'docbook-xsl' 'w3m')
+source=("git+https://github.com/neomutt/neomutt.git#branch=main"
+ "default-ca-certificates.patch")
+sha256sums=('SKIP'
+ '571716b8979e9b43328416c3c56eff228b6c58355d7c080b8987ea89c6360776')
conflicts=('neomutt')
provides=('neomutt')
pkgver() {
cd "$_pkgname"
- git describe --long --tags | sed 's/^neomutt-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed -r 's/(.*)-(.*)-/\1.r\2./; s/-//g'
}
-build() {
+prepare() {
cd "$_pkgname"
+ patch -Np1 -i "$srcdir/default-ca-certificates.patch"
+}
+build() {
+ cd "$_pkgname"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/lib \
--gpgme \
- --enable-lua \
+ --sqlite \
+ --autocrypt \
+ --lua \
--notmuch \
--gss \
- --ssl \
+ --gnutls \
--sasl \
- --with-ui=ncurses \
- --with-idn=/usr \
- --gdbm
+ --with-idn2=/usr \
+ --disable-idn \
+ --idn2 \
+ --bdb \
+ --lmdb \
+ --kyotocabinet \
+ --gdbm \
+ --lz4 \
+ --zlib \
+ --zstd
make
}
diff --git a/default-ca-certificates.patch b/default-ca-certificates.patch
new file mode 100644
index 000000000000..d74509a5b3be
--- /dev/null
+++ b/default-ca-certificates.patch
@@ -0,0 +1,12 @@
+--- a/docs/neomuttrc.head
++++ b/docs/neomuttrc.head.new
+@@ -48,6 +48,9 @@ bind browser y exit
+ # be undone with unmime_lookup.
+ mime_lookup application/octet-stream
+
++# System-wide CA file managed by the ca-certificates package
++set ssl_ca_certificates_file="/etc/ssl/certs/ca-certificates.crt"
++
+ ##
+ ## *** DEFAULT SETTINGS FOR THE ATTACHMENTS PATCH ***
+ ##