summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD62
2 files changed, 35 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f231bf0bdb9..a42592421dc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sat Feb 3 08:22:20 UTC 2018
pkgbase = neomutt-git
- pkgdesc = The New Mutt: powerful text-based mail client with all the best feature patches
+ pkgdesc = A version of mutt with added features - development branch
pkgver = 20171215.r144.gb7da81ad
- pkgrel = 1
+ pkgrel = 2
url = http://www.neomutt.org/
arch = i686
arch = x86_64
@@ -9,10 +11,11 @@ pkgbase = neomutt-git
makedepends = git
makedepends = gnupg
makedepends = libxslt
+ makedepends = docbook-xsl
+ makedepends = lynx
depends = notmuch-runtime
depends = lua
- depends = python
- optdepends = urlview: for url menu
+ optdepends = python: keybase.py
provides = neomutt
conflicts = neomutt
source = git+https://github.com/neomutt/neomutt.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 709d6fbed6dc..134cca4c9cb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,49 @@
-# Maintainer: Sean Haugh <seanphaugh@gmail.com>
+# Maintainer: Alad Wenter <alad@mailbox.org>
+# Contributor: Sean Haugh <seanphaugh@gmail.com>
# Contributor: Chris Salzberg <chris@dejimata.com>
_pkgname=neomutt
pkgname=neomutt-git
pkgver=20171215.r144.gb7da81ad
-pkgrel=1
-pkgdesc='The New Mutt: powerful text-based mail client with all the best feature patches'
+pkgrel=2
+pkgdesc='A version of mutt with added features - development branch'
url='http://www.neomutt.org/'
license=('GPL')
source=('git+https://github.com/neomutt/neomutt.git#branch=master')
sha256sums=('SKIP')
arch=('i686' 'x86_64')
-depends=('notmuch-runtime' 'lua' 'python')
-optdepends=('urlview: for url menu')
-makedepends=('git' 'gnupg' 'libxslt')
+depends=('notmuch-runtime' 'lua')
+optdepends=('python: keybase.py')
+makedepends=('git' 'gnupg' 'libxslt' 'docbook-xsl' 'lynx')
conflicts=('neomutt')
provides=('neomutt')
pkgver() {
- cd "${srcdir}/${_pkgname}"
-
- # Get the version number.
- git describe --long --tags | sed 's/^neomutt-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^neomutt-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_pkgname}"
-
- # Configure the build.
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib \
- --enable-debug \
- --enable-pgp \
- --enable-gpgme \
- --enable-notmuch \
- --enable-lua \
- --with-gss=/usr \
- --with-ssl=/usr \
- --with-sasl=/usr \
- --with-idn=/usr \
- --with-gdbm=/usr
+ cd "$_pkgname"
- # Build it!
- make
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --gpgme \
+ --enable-lua \
+ --notmuch \
+ --gss \
+ --ssl \
+ --sasl \
+ --with-ui=ncurses \
+ --with-idn=/usr \
+ --gdbm
+ make
}
package() {
- cd "${srcdir}/${_pkgname}"
-
- # Install the program.
- make DESTDIR="${pkgdir}" install
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
}
-# vim: ft=sh ts=2 sw=2 et
+
+# vim: ft=sh ts=4 sw=4 et