summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f8d53de796a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = neon-threadsafe
+ pkgdesc = HTTP and WebDAV client library with a C interface
+ pkgver = 0.30.0
+ pkgrel = 1
+ url = http://www.webdav.org/neon/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ depends = krb5
+ depends = expat
+ depends = ca-certificates
+ provides = neon
+ conflicts = neon
+ options = libtool
+ source = http://www.webdav.org/neon/neon-0.30.0.tar.gz
+ md5sums = fb60b3a124eeec441937a812c456fd94
+
+pkgname = neon-threadsafe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e78cf3b726cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=neon-threadsafe
+_pkgname=neon
+pkgver=0.30.0
+pkgrel=1
+pkgdesc="HTTP and WebDAV client library with a C interface"
+arch=('i686' 'x86_64')
+url="http://www.webdav.org/neon/"
+license=('GPL' 'LGPL')
+depends=('krb5' 'expat' 'ca-certificates')
+options=('libtool') # FS#16067
+source=("http://www.webdav.org/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('fb60b3a124eeec441937a812c456fd94')
+conflicts=('neon')
+provides=('neon')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --with-expat \
+ --enable-shared \
+ --enable-threadsafe-ssl \
+ --disable-static \
+ --with-ssl=openssl \
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}