summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Remove-unnecessary-braces-around-if-condition.patch30
-rw-r--r--PKGBUILD8
3 files changed, 37 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c32f09706c0..ab81fe5b8ae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovide
pkgdesc = No Nonsense Neovim Client in Rust
pkgver = 0.6.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/Kethku/neovide
arch = x86_64
license = MIT
@@ -18,9 +18,9 @@ pkgbase = neovide
provides = neovide
conflicts = neovide-git
source = neovide-0.6.0.tar.gz::https://github.com/Kethku/neovide/archive/0.6.0.tar.gz
- source = 0001-Remove-unnecessary-braces-around-if-condition.patch::https://github.com/Kethku/neovide/commit/c4890065a33ac265184400ab83743702efbaf291.patch
+ source = 0001-Remove-unnecessary-braces-around-if-condition.patch
sha256sums = 4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd
- sha256sums = cfd5f5fa8015b377153d60515f2d797b9241d8df60633cfd85c9a24204541d9b
+ sha256sums = 53c28f4f6d9f0dee319188d1dc733ace0500f8c616941110936967e962e605dc
pkgname = neovide
diff --git a/0001-Remove-unnecessary-braces-around-if-condition.patch b/0001-Remove-unnecessary-braces-around-if-condition.patch
new file mode 100644
index 000000000000..2eb29daee44e
--- /dev/null
+++ b/0001-Remove-unnecessary-braces-around-if-condition.patch
@@ -0,0 +1,30 @@
+diff --git a/src/bridge/ui_commands.rs b/src/bridge/ui_commands.rs
+index 77f6774..79767b1 100644
+--- a/src/bridge/ui_commands.rs
++++ b/src/bridge/ui_commands.rs
+@@ -42,7 +42,7 @@ impl UiCommand {
+ action,
+ position: (grid_x, grid_y),
+ } => {
+- if { EDITOR.lock().mouse_enabled } {
++ if EDITOR.lock().mouse_enabled {
+ nvim.input_mouse("left", &action, "", 0, grid_y as i64, grid_x as i64)
+ .await
+ .expect("Mouse Input Failed");
+@@ -52,14 +52,14 @@ impl UiCommand {
+ direction,
+ position: (grid_x, grid_y),
+ } => {
+- if { EDITOR.lock().mouse_enabled } {
++ if EDITOR.lock().mouse_enabled {
+ nvim.input_mouse("wheel", &direction, "", 0, grid_y as i64, grid_x as i64)
+ .await
+ .expect("Mouse Scroll Failed");
+ }
+ }
+ UiCommand::Drag(grid_x, grid_y) => {
+- if { EDITOR.lock().mouse_enabled } {
++ if EDITOR.lock().mouse_enabled {
+ nvim.input_mouse("left", "drag", "", 0, grid_y as i64, grid_x as i64)
+ .await
+ .expect("Mouse Drag Failed");
diff --git a/PKGBUILD b/PKGBUILD
index bdcb5e1191f2..1f452b9b6949 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=neovide
pkgver=0.6.0
-pkgrel=5
+pkgrel=6
pkgdesc='No Nonsense Neovim Client in Rust'
arch=('x86_64')
url='https://github.com/Kethku/neovide'
@@ -12,13 +12,13 @@ makedepends=('rust' 'gtk3' 'cmake' 'sdl2' 'make')
provides=("neovide")
conflicts=("neovide-git")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
- "0001-Remove-unnecessary-braces-around-if-condition.patch::https://github.com/Kethku/neovide/commit/c4890065a33ac265184400ab83743702efbaf291.patch")
+ "0001-Remove-unnecessary-braces-around-if-condition.patch")
sha256sums=('4daaad6ff527c299b9fa3db677bc1320b9596efbc27853ed730a57df6c1568fd'
- 'cfd5f5fa8015b377153d60515f2d797b9241d8df60633cfd85c9a24204541d9b')
+ '53c28f4f6d9f0dee319188d1dc733ace0500f8c616941110936967e962e605dc')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -c -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
+ patch -p1 < "${srcdir}/0001-Remove-unnecessary-braces-around-if-condition.patch"
sed -i 's/debug = true/opt-level = 3\ndebug = false/' Cargo.toml
sed -i 's/Icon=neovide/Icon=nvim/' assets/neovide.desktop
}