summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa8ea3c66a22..7df735b226df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-bufexplorer
pkgdesc = A simple buffer list/switcher for Neovim
- pkgver = 7.4.12
+ pkgver = 7.4.26
pkgrel = 1
url = https://github.com/jlanzarotta/bufexplorer
install = nvim-doc.install
@@ -9,8 +9,7 @@ pkgbase = neovim-bufexplorer
license = BSD
depends = neovim
conflicts = neovim-buffexplorer
- source = neovim-bufexplorer.tar.gz::https://github.com/jlanzarotta/bufexplorer/archive/7.4.12.tar.gz
- sha256sums = bcd8549fdd64d149356f1995eaf3f7cd6e0996d8c9128b41085772a24e13a00a
+ source = neovim-bufexplorer.tar.gz::https://github.com/jlanzarotta/bufexplorer/archive/v7.4.26.tar.gz
+ sha256sums = 3302df8f942729e2735f5f9c918f70cd308225fc6e1d3adc8ffb86988d00db80
pkgname = neovim-bufexplorer
-
diff --git a/PKGBUILD b/PKGBUILD
index 6cc0438dcfb6..9ec498d204a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
#Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=neovim-bufexplorer
-pkgver=7.4.12
+pkgver=7.4.26
pkgrel=1
pkgdesc="A simple buffer list/switcher for Neovim"
arch=('any')
@@ -11,8 +11,8 @@ license=('BSD')
depends=('neovim')
groups=('neovim-plugins')
install=nvim-doc.install
-source=("$pkgname.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('bcd8549fdd64d149356f1995eaf3f7cd6e0996d8c9128b41085772a24e13a00a')
+source=("$pkgname.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('3302df8f942729e2735f5f9c918f70cd308225fc6e1d3adc8ffb86988d00db80')
conflicts=('neovim-buffexplorer')
package() {
@@ -20,7 +20,7 @@ package() {
installpath="${pkgdir}/usr/share/nvim/runtime"
- install -D -m644 doc/bufexplorer.txt $installpath/doc/bufexplorer.txt
- install -D -m644 plugin/bufexplorer.vim $installpath/plugin/bufexplorer.vim
+ install -D -m644 doc/* -t "$installpath/doc/"
+ install -D -m644 plugin/* -t "$installpath/plugin/"
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}