summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--coc-neovim-doc.hook4
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 529e34d0db13..ceccba919ff1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = neovim-coc
source = https://github.com/neoclide/coc.nvim/archive/v0.0.78.tar.gz
source = coc-neovim-doc.hook
sha256sums = 1e9634b9c5de3557d8ecf3057fcaa1958d70a8d433eec2da19d88f8d486c2695
- sha256sums = 70cd7d959ea6ca973bd761b6deab922bfa34dd725aab636a0bbc5fbfd60cabaa
+ sha256sums = 2e4d498a34a920452764dffb728cd65526bff7bfbda8599f4de5b5ff427d8d5b
pkgname = neovim-coc
diff --git a/PKGBUILD b/PKGBUILD
index a0546d42d758..66b7a1a40e87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ conflicts=('neovim-coc')
source=('https://github.com/neoclide/coc.nvim/archive/v0.0.78.tar.gz'
'coc-neovim-doc.hook')
sha256sums=('1e9634b9c5de3557d8ecf3057fcaa1958d70a8d433eec2da19d88f8d486c2695'
- '70cd7d959ea6ca973bd761b6deab922bfa34dd725aab636a0bbc5fbfd60cabaa')
+ '2e4d498a34a920452764dffb728cd65526bff7bfbda8599f4de5b5ff427d8d5b')
build() {
cd "${srcdir}/coc.nvim-${pkgver}"
@@ -23,7 +23,7 @@ build() {
package() {
cd "${srcdir}/coc.nvim-${pkgver}"
find autoload bin build data doc package.json plugin -type f -exec \
- install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/coc/start/coc.nvim/{}" \;
+ install -Dm 644 '{}' "${pkgdir}/usr/local/share/nvim/site/pack/coc/start/coc.nvim/{}" \;
install -Dm 644 "${srcdir}/coc.nvim-${pkgver}/LICENSE.md" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
install -Dm 644 "${srcdir}"/coc-neovim-doc.hook "${pkgdir}"/usr/share/libalpm/hooks/coc-neovim-doc.hook
diff --git a/coc-neovim-doc.hook b/coc-neovim-doc.hook
index 8351ddd27b37..70188dd7977a 100644
--- a/coc-neovim-doc.hook
+++ b/coc-neovim-doc.hook
@@ -3,9 +3,9 @@ Operation = Install
Operation = Upgrade
Operation= Remove
Type = Path
-Target = usr/share/nvim/runtime/pack/coc/start/coc.nvim/doc/
+Target = usr/local/share/nvim/site/pack/coc/start/coc.nvim/doc/
[Action]
Description = Updating Vim help tags...
-Exec = /usr/bin/nvim -es --cmd ":helptags /usr/share/nvim/runtime/pack/coc/start/coc.nvim/doc" --cmd ":q"
+Exec = /usr/bin/nvim -es --cmd ":helptags /usr/local/share/nvim/site/pack/coc/start/coc.nvim/doc" --cmd ":q"
When = PostTransaction