summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD1
2 files changed, 3 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 535e97b30d7f..98e72febe7cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,8 @@ pkgbase = neovim-coc-git
makedepends = git
depends = neovim
depends = nodejs
+ optdepends = npm: for installing coc extensions
+ optdepends = yarn: for installing coc extensions
provides = neovim-coc
conflicts = neovim-coc
source = git+https://github.com/neoclide/coc.nvim.git#branch=release
diff --git a/PKGBUILD b/PKGBUILD
index c79f46f429e9..dae6b6d62004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,6 +6,7 @@ arch=('any')
url='https://github.com/neoclide/coc.nvim'
license=('MIT')
depends=('neovim' 'nodejs')
+optdepends=('npm: for installing coc extensions' 'yarn: for installing coc extensions')
makedepends=('git')
provides=('neovim-coc')
conflicts=('neovim-coc')