summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f4fa73ae8a4..3ce870ff8bb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = neovim-coc-git-git
url = https://github.com/neoclide/coc-git
arch = any
groups = neovim-coc-extras-git
- license =
+ license = MIT
makedepends = yarn
makedepends = npm
depends = neovim-coc
diff --git a/PKGBUILD b/PKGBUILD
index befb5f7fef6a..f217d05a21b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url='https://github.com/neoclide/coc-git'
depends=('neovim-coc' 'git')
makedepends=('yarn' 'npm')
_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
-license=('')
+license=('MIT')
groups=('neovim-coc-extras-git')
provides=("${_pkgname}-git")
conflicts=("${_pkgname}-git")
@@ -24,12 +24,12 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
- yarn install --frozen-lockfile
+ yarn install --frozen-lockfile --preferred-cache-folder "${srcdir}/.cache/yarn"
yarn pack
tar xvf *.tgz
rm *.tgz
cd package
- npm install --only=production --no-lockfile --ignore-scripts
+ npm install --only=production --no-lockfile --ignore-scripts --cache "${srcdir}/.cache/npm"
}
package() {
@@ -37,4 +37,6 @@ package() {
find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
+ find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ chown -R root:root "${pkgdir}"
}