summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--package.json.patch10
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19054b560fa2..5dff2540d083 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-coc-go-git
pkgdesc = Go language server extension using gopls for coc.nvim
- pkgver = 0.9.2.r2.g6d13daa
+ pkgver = 0.13.3.r6.ga0e68ff
pkgrel = 1
url = https://github.com/josa42/coc-go
arch = any
@@ -8,10 +8,13 @@ pkgbase = neovim-coc-go-git
makedepends = yarn
makedepends = git
depends = neovim-coc
+ depends = gopls
provides = neovim-coc-go
conflicts = neovim-coc-go
source = coc-go::git+https://github.com/josa42/coc-go.git
+ source = package.json.patch
sha256sums = SKIP
+ sha256sums = c694b3c9def3ddb1bce2dfcef6721a43a9458e96c117e9a2ba911e4b4bfd492b
pkgname = neovim-coc-go-git
diff --git a/PKGBUILD b/PKGBUILD
index 2f6b68e9b409..6e16c48bf8a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,15 @@ pkgname="${_variant}-${_extname}-git"
provides=("${_variant}-${_extname}")
conflicts=("${_variant}-${_extname}")
arch=('any')
-depends=("${_variant}-coc")
+depends=("${_variant}-coc" 'gopls')
makedepends=('yarn' 'git')
license=('MIT')
-source=("${_extname}::git+${url}.git")
-pkgver=0.9.2.r2.g6d13daa
+source=("${_extname}::git+${url}.git"
+ 'package.json.patch')
+pkgver=0.13.3.r6.ga0e68ff
pkgrel=1
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ 'c694b3c9def3ddb1bce2dfcef6721a43a9458e96c117e9a2ba911e4b4bfd492b')
pkgver() {
cd "${srcdir}/${_extname}"
@@ -39,5 +41,6 @@ package() {
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
rm -rf "${srcdir}/${_extname}/package"
find "$pkgdir" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+ patch "$pkgdir/$_packdir/package.json" <"$srcdir/package.json.patch"
chown -R root:root "${pkgdir}"
}
diff --git a/package.json.patch b/package.json.patch
new file mode 100644
index 000000000000..5b95d5b6e1c1
--- /dev/null
+++ b/package.json.patch
@@ -0,0 +1,10 @@
+--- package.json.old 2021-03-28 10:33:24.557720327 +0800
++++ package.json.new 2021-03-28 10:35:32.467725438 +0800
+@@ -87,6 +87,7 @@
+ },
+ "go.goplsPath": {
+ "type": "string",
++ "default": "/usr/bin/gopls",
+ "description": "Path to `gopls` bin (Change requires `:CocRestart`)"
+ },
+ "go.goplsArgs": {