summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--neovim-coc-marketplace-git.install7
3 files changed, 3 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8865746f9e1..722dc9e21b3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,19 +3,15 @@ pkgbase = neovim-coc-marketplace-git
pkgver = 1.4.0.r109.ga1ec912
pkgrel = 1
url = https://github.com/fannheyward/coc-marketplace
- install = neovim-coc-marketplace-git.install
arch = any
license = MIT
makedepends = git
makedepends = yarn
- makedepends = npm
depends = neovim-coc
provides = neovim-coc-marketplace
conflicts = neovim-coc-marketplace
source = coc-marketplace::git+https://github.com/fannheyward/coc-marketplace.git
- source = neovim-coc-marketplace-git.install
sha256sums = SKIP
- sha256sums = 28cc66de4745e00291dc58a32588eb4df5cb52f2a780353f975e58efbc1d73a4
pkgname = neovim-coc-marketplace-git
diff --git a/PKGBUILD b/PKGBUILD
index 0682929317a6..1a64ff52b047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,13 @@ pkgdesc='coc.nvim extensions marketplace'
arch=('any')
url='https://github.com/fannheyward/coc-marketplace'
depends=('neovim-coc')
-makedepends=('git' 'yarn' 'npm')
+makedepends=('git' 'yarn')
_packdir="usr/share/nvim/runtime/pack/coc/start/${_extname}"
license=('MIT')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-install="${pkgname}.install"
-source=("${_extname}::git+${url}.git"
- "${pkgname}.install")
-sha256sums=('SKIP'
- '28cc66de4745e00291dc58a32588eb4df5cb52f2a780353f975e58efbc1d73a4')
+source=("${_extname}::git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_extname}"
diff --git a/neovim-coc-marketplace-git.install b/neovim-coc-marketplace-git.install
deleted file mode 100644
index ff4efebfb676..000000000000
--- a/neovim-coc-marketplace-git.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- BBLUE='\033[1;34m'
- GREEN='\033[0;32m'
- NC='\033[0m' # No Color
-
- printf "\n${BBLUE}Execute the following command in nvim to search extensions:\n\n ${GREEN}:CocList marketplace${NC}\n\n"
-}