summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a9bc7bad54d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-coc-marketplace-git
+ pkgdesc = coc.nvim extensions marketplace
+ pkgver = v1.4.0.r109.ga1ec912
+ pkgrel = 1
+ url = https://github.com/fannheyward/coc-marketplace
+ arch = any
+ groups = neovim-coc-extras-git
+ license =
+ makedepends = git
+ makedepends = yarn
+ makedepends = npm
+ depends = neovim-coc
+ provides = neovim-coc-marketplace
+ conflicts = neovim-coc-marketplace
+ source = coc-marketplace::git+https://github.com/fannheyward/coc-marketplace.git
+ sha256sums = SKIP
+
+pkgname = neovim-coc-marketplace-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35afa6909588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=neovim-coc-marketplace-git
+_pkgname=neovim-coc-marketplace
+_extname=coc-marketplace
+pkgdesc='coc.nvim extensions marketplace'
+arch=('any')
+url='https://github.com/fannheyward/coc-marketplace'
+depends=('neovim-coc')
+makedepends=('git' 'yarn' 'npm')
+_packdir="usr/local/share/nvim/site/pack/coc/start/${_extname}"
+license=('')
+groups=('neovim-coc-extras-git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_extname}::git+${url}.git")
+pkgver=v1.4.0.r109.ga1ec912
+pkgrel=1
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_extname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_extname}"
+ yarn install --frozen-lockfile
+}
+
+package() {
+ cd "${srcdir}/${_extname}"
+ find lib/*.js package.json -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+}