summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
-rw-r--r--neovim-coc-marketplace-git.install7
3 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a9bc7bad54d..ef346b17d962 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = neovim-coc-marketplace-git
pkgver = v1.4.0.r109.ga1ec912
pkgrel = 1
url = https://github.com/fannheyward/coc-marketplace
+ install = neovim-coc-marketplace-git.install
arch = any
groups = neovim-coc-extras-git
license =
@@ -13,7 +14,9 @@ pkgbase = neovim-coc-marketplace-git
provides = neovim-coc-marketplace
conflicts = neovim-coc-marketplace
source = coc-marketplace::git+https://github.com/fannheyward/coc-marketplace.git
+ source = neovim-coc-marketplace-git.install
sha256sums = SKIP
+ sha256sums = 28cc66de4745e00291dc58a32588eb4df5cb52f2a780353f975e58efbc1d73a4
pkgname = neovim-coc-marketplace-git
diff --git a/PKGBUILD b/PKGBUILD
index 80a30905b339..d5d9549a07a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,8 @@
pkgname=neovim-coc-marketplace-git
_pkgname=neovim-coc-marketplace
_extname=coc-marketplace
+pkgver=v1.4.0.r109.ga1ec912
+pkgrel=1
pkgdesc='coc.nvim extensions marketplace'
arch=('any')
url='https://github.com/fannheyward/coc-marketplace'
@@ -12,10 +14,11 @@ license=('')
groups=('neovim-coc-extras-git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_extname}::git+${url}.git")
-pkgver=v1.4.0.r109.ga1ec912
-pkgrel=1
-sha256sums=('SKIP')
+install="${pkgname}.install"
+source=("${_extname}::git+${url}.git"
+ "${pkgname}.install")
+sha256sums=('SKIP'
+ '28cc66de4745e00291dc58a32588eb4df5cb52f2a780353f975e58efbc1d73a4')
pkgver() {
cd "${srcdir}/${_extname}"
diff --git a/neovim-coc-marketplace-git.install b/neovim-coc-marketplace-git.install
new file mode 100644
index 000000000000..ff4efebfb676
--- /dev/null
+++ b/neovim-coc-marketplace-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ BBLUE='\033[1;34m'
+ GREEN='\033[0;32m'
+ NC='\033[0m' # No Color
+
+ printf "\n${BBLUE}Execute the following command in nvim to search extensions:\n\n ${GREEN}:CocList marketplace${NC}\n\n"
+}