summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD21
-rw-r--r--nvim-doc.install14
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2ca002f9bd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = neovim-doxygentoolkit
+ pkgdesc = This script simplify doxygen documentation in C/C++
+ pkgver = 0.2.13
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=987
+ install = nvim-doc.install
+ arch = any
+ groups = neovim-plugins
+ license = GPL
+ depends = neovim
+ source = DoxygenToolkit.vim::http://www.vim.org/scripts/download_script.php?src_id=14064
+ md5sums = 669e14133afa26b2b72c48a9315d8f7d
+
+pkgname = neovim-doxygentoolkit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7123c0a23024
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# package src/pkg archives, downloaded sources
+*.tar*
+*.tgz
+*.zip
+
+# signed sources
+*.asc
+*.sig
+
+# subfolders, e.g. source or built package trees, vcs
+*/**/
+!neovim-plugins/*
+# backup files
+*~
+*.bak
+pkg
+src
+*xpi
+*tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df6483194392
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Joost Bremmer <toost.b@gmail.com>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=neovim-doxygentoolkit
+pkgver=0.2.13
+_scriptid=14064
+pkgrel=1
+pkgdesc="This script simplify doxygen documentation in C/C++"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=987"
+license=('GPL')
+depends=('neovim')
+groups=('neovim-plugins')
+source=(DoxygenToolkit.vim::"http://www.vim.org/scripts/download_script.php?src_id=$_scriptid")
+md5sums=('669e14133afa26b2b72c48a9315d8f7d')
+install='nvim-doc.install'
+
+package() {
+ cd "${srcdir}"
+ install -D -m644 DoxygenToolkit.vim "${pkgdir}/usr/share/nvim/runtime/plugin/DoxygenToolkit.vim"
+}
diff --git a/nvim-doc.install b/nvim-doc.install
new file mode 100644
index 000000000000..79795d84c37b
--- /dev/null
+++ b/nvim-doc.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo -n "Updating neovim help tags..."
+ /usr/bin/nvim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}