summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD40
-rw-r--r--ex.sh5
-rw-r--r--exim.sh5
-rw-r--r--neovim-drop-in.install7
-rw-r--r--rview.sh5
-rw-r--r--rvim.sh5
-rw-r--r--view.sh5
-rw-r--r--vimdiff.sh5
9 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b462ed05c9fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = neovim-drop-in
+ pkgdesc = Emulate vim and vi executables with neovim
+ pkgver = 1
+ pkgrel = 1
+ url = https://neovim.io/doc/user/vim_diff.html
+ install = neovim-drop-in.install
+ arch = any
+ license = custom:none
+ depends = neovim
+ optdepends = xxd: For editing binary files
+ provides = vi
+ provides = vim
+ provides = vim-runtime
+ conflicts = gvim
+ conflicts = neovim-symlinks
+ conflicts = vi
+ conflicts = vim
+ source = ex.sh
+ source = exim.sh
+ source = rview.sh
+ source = rvim.sh
+ source = view.sh
+ source = vimdiff.sh
+ md5sums = 43a308b1bd6ff01af18713cd396d9613
+ md5sums = 7bfc8f55728827a9cfef456bc1b25e2c
+ md5sums = 63df8ad2cf566c0b58c621e383f46e0f
+ md5sums = a970a2b303ea9f116eac6c91c045bd4c
+ md5sums = 7e4047ace5a1f0793e707653f4dc0432
+ md5sums = 3e470ab2dc0a42e1ada96869e19ac094
+
+pkgname = neovim-drop-in
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b5075e52102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Daniel Greve <greve.daniel.l@gmail.com>
+
+pkgname=neovim-drop-in
+pkgver=1
+pkgrel=1
+pkgdesc='Emulate vim and vi executables with neovim'
+arch=('any')
+url='https://neovim.io/doc/user/vim_diff.html'
+license=('custom:none')
+depends=('neovim')
+optdepends=('xxd: For editing binary files')
+provides=('vi' 'vim' 'vim-runtime')
+conflicts=('gvim' 'neovim-symlinks' 'vi' 'vim')
+source=('ex.sh' 'exim.sh' 'rview.sh' 'rvim.sh' 'view.sh' 'vimdiff.sh')
+install=neovim-drop-in.install
+md5sums=('43a308b1bd6ff01af18713cd396d9613'
+ '7bfc8f55728827a9cfef456bc1b25e2c'
+ '63df8ad2cf566c0b58c621e383f46e0f'
+ 'a970a2b303ea9f116eac6c91c045bd4c'
+ '7e4047ace5a1f0793e707653f4dc0432'
+ '3e470ab2dc0a42e1ada96869e19ac094')
+
+## To do: Provide vimtutor
+package() {
+ local _script
+ for _script in "${source[@]}"; do
+ install -Dm755 "${_script}" "${pkgdir}/usr/bin/${_script%.sh}"
+ done
+
+ local _link
+ for _link in 'edit' 'vedit' 'vi' 'vim'; do
+ ln -s 'nvim' "${pkgdir}/usr/bin/${_link}"
+ done
+
+ install -dm755 "${pkgdir}/usr/share/man/man1"
+ local _man
+ for _man in 'vi' 'vim' 'vimdiff'; do
+ ln -s 'nvim.1.gz' "${pkgdir}/usr/share/man/man1/${_man}.1.gz"
+ done
+}
diff --git a/ex.sh b/ex.sh
new file mode 100644
index 000000000000..a6d8c55657ee
--- /dev/null
+++ b/ex.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# Emulate ex
+#
+exec nvim -e "$@"
diff --git a/exim.sh b/exim.sh
new file mode 100644
index 000000000000..2c3a9fd737c8
--- /dev/null
+++ b/exim.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# Emulate exim
+#
+exec nvim -E "$@"
diff --git a/neovim-drop-in.install b/neovim-drop-in.install
new file mode 100644
index 000000000000..0ea0ce43d10a
--- /dev/null
+++ b/neovim-drop-in.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo ':: To use pacman-installed vim addons with neovim, enable the default vim runtime'
+ echo ' path by adding the following line to your neovim configuration:'
+ echo
+ echo ' set runtimepath^=/usr/share/vim/vimfiles'
+ echo
+}
diff --git a/rview.sh b/rview.sh
new file mode 100644
index 000000000000..b32be2b48c6d
--- /dev/null
+++ b/rview.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# Emulate rview
+#
+exec nvim -RZ "$@"
diff --git a/rvim.sh b/rvim.sh
new file mode 100644
index 000000000000..56df83de96d0
--- /dev/null
+++ b/rvim.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# Emulate rvim
+#
+exec nvim -Z "$@"
diff --git a/view.sh b/view.sh
new file mode 100644
index 000000000000..8af8e50281e6
--- /dev/null
+++ b/view.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# Emulate view
+#
+exec nvim -R "$@"
diff --git a/vimdiff.sh b/vimdiff.sh
new file mode 100644
index 000000000000..3be08ebee497
--- /dev/null
+++ b/vimdiff.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# Emulate vimdiff
+#
+exec nvim -d "$@"