summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e34315c0bc7..dc7b0b5a7b4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-git
pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs.
- pkgver = 0.r4306.68e5968
+ pkgver = 0.1.0.r0.gc4826c3
pkgrel = 1
url = https://neovim.io
install = neovim-git.install
@@ -22,7 +22,7 @@ pkgbase = neovim-git
optdepends = python-neovim: for Python 3 plugin support (see :help nvim-python)
optdepends = xclip: for clipboard support (or xsel) (see :help nvim-clipboard)
optdepends = xsel: for clipboard support (or xclip) (see :help nvim-clipboard)
- provides = neovim=0.r4306.68e5968
+ provides = neovim=0.1.0.r0.gc4826c3
conflicts = neovim
source = neovim-git::git+https://github.com/neovim/neovim.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f8c32a133c4c..18b5cafc3ee2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Florian Hahn <flo@fhahn.com>
pkgname=neovim-git
-pkgver=0.r4306.68e5968
+pkgver=0.1.0.r0.gc4826c3
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
arch=('i686' 'x86_64')
@@ -22,14 +22,14 @@ install=neovim-git.install
pkgver() {
cd "${pkgname}"
- printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
mkdir -p "${pkgname}/build"
cd "${pkgname}/build"
cmake -G 'Unix Makefiles' \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_BUILD_TYPE=Dev \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_JEMALLOC=ON \
..