summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--neovim.install15
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f9c2e2e8991
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = neovim-nightly
+ pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs - Nightly Build
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://neovim.io
+ install = neovim.install
+ arch = x86_64
+ license = custom:neovim
+ optdepends = python2-neovim: for Python 2 plugin support, see :help python
+ optdepends = python-neovim: for Python 3 plugin support, see :help python
+ optdepends = xclip: for clipboard support, see :help clipboard
+ optdepends = xsel: for clipboard support, see :help clipboard
+ provides = neovim
+ conflicts = neovim
+ source = https://github.com/neovim/neovim/releases/download/nightly/nvim-linux64.tar.gz
+ sha512sums = 3a3c599c10d094ae7e7742e3330c2af996290ede5fc30e3e7017bc55716e0ff8ae6cb663cd6a63016b222d56d38e9716f7fa4b5efeed21535e46903fe8a635d8
+
+pkgname = neovim-nightly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc6187f67bb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Kevin Del Castillo R. <lans9831@gmail.com>
+
+_pkgname=neovim
+pkgname=neovim-nightly
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs - Nightly Build'
+arch=('x86_64')
+url='https://neovim.io'
+license=('custom:neovim')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+optdepends=('python2-neovim: for Python 2 plugin support, see :help python'
+ 'python-neovim: for Python 3 plugin support, see :help python'
+ 'xclip: for clipboard support, see :help clipboard'
+ 'xsel: for clipboard support, see :help clipboard')
+
+source=('https://github.com/neovim/neovim/releases/download/nightly/nvim-linux64.tar.gz')
+sha512sums=('3a3c599c10d094ae7e7742e3330c2af996290ede5fc30e3e7017bc55716e0ff8ae6cb663cd6a63016b222d56d38e9716f7fa4b5efeed21535e46903fe8a635d8')
+install=neovim.install
+
+check() {
+ cd "${srcdir}/nvim-linux64"
+ ./bin/nvim --version
+ ./bin/nvim --headless -u NONE -i NONE -c ':quit'
+}
+
+package() {
+ cd "${srcdir}/nvim-linux64"
+
+ mkdir -p "${pkgdir}/usr/bin"
+
+ cp -r share "${pkgdir}/usr/"
+ install bin/nvim "${pkgdir}/usr/bin"
+
+ # Make Arch vim packages work
+ mkdir -p "${pkgdir}"/usr/share/vim
+ echo "set runtimepath+=/usr/share/vim/vimfiles" > "${pkgdir}"/usr/share/nvim/sysinit.vim
+}
+
+# vim:set sw=2 sts=2 et:
diff --git a/neovim.install b/neovim.install
new file mode 100644
index 000000000000..ce485f55a278
--- /dev/null
+++ b/neovim.install
@@ -0,0 +1,15 @@
+# $1: new package version
+post_install() {
+ echo ":: The Neovim executable is called 'nvim'."
+ echo ":: If you are already familiar with Vim, see ':help nvim-from-vim'"
+ echo " to get started."
+}
+
+post_update() {
+ echo ":: If you have any questions, check the following page first:"
+ echo " https://github.com/neovim/neovim/wiki/FAQ"
+ echo ":: Remember this a pre-release build, see 'Following HEAD' for more info"
+ echo " https://github.com/neovim/neovim/wiki/Following-HEAD"
+}
+
+# vim:set sw=2 sts=2 et: