summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0edf1bd11d05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = neovim-nui-git
+ pkgdesc = UI component library for Neovim
+ pkgver = r84.69dfae4
+ pkgrel = 1
+ url = https://github.com/muniftanjim/nui.nvim
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim>=0.5.0
+ provides = neovim-nui
+ conflicts = neovim-nui
+ source = neovim-nui-git::git+https://github.com/muniftanjim/nui.nvim
+ md5sums = SKIP
+
+pkgname = neovim-nui-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3919b48cdf42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-nui-git
+pkgver=r84.69dfae4
+pkgrel=1
+pkgdesc="UI component library for Neovim"
+arch=('any')
+url="https://github.com/muniftanjim/nui.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim>=0.5.0')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}