summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c54027eb9986
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = neovim-polyglot-git
+ pkgdesc = A solid language pack for Vim.
+ pkgver = r540.56121b4
+ pkgrel = 1
+ url = https://github.com/sheerun/vim-polyglot
+ arch = any
+ license =
+ makedepends = git
+ depends = neovim
+ provides = neovim-polyglot
+ conflicts = neovim-polyglot
+ source = git+https://github.com/sheerun/vim-polyglot.git
+ sha256sums = SKIP
+
+pkgname = neovim-polyglot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab4e630fca32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=neovim-polyglot-git
+pkgver=r540.56121b4
+pkgrel=1
+pkgdesc='A solid language pack for Vim.'
+arch=('any')
+url='https://github.com/sheerun/vim-polyglot'
+license=('')
+depends=('neovim')
+makedepends=('git')
+provides=('neovim-polyglot')
+conflicts=('neovim-polyglot')
+source=('git+https://github.com/sheerun/vim-polyglot.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/vim-polyglot"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/vim-polyglot"
+ find after autoload compiler ctags extras ftdetect ftplugin indent syntax -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/nvim/runtime/pack/vim-polyglot/start/vim-polyglot/{}" \;
+}
+