summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f64ac82bfab8..e13a8dbfc3bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = neovim-surround-opt-git
- pkgdesc = Provides mappings to easily delete, change, and add paired "surroundings."
- pkgver = 109.5970688
+ pkgdesc = Add/change/delete surrounding delimiter pairs with ease.
+ pkgver = 215.10b20ca
pkgrel = 1
- url = https://github.com/tpope/vim-surround
+ url = https://github.com/kylechui/nvim-surround
arch = any
- license = custom:vim
+ license = MIT
makedepends = git
depends = neovim
- source = git+https://github.com/tpope/vim-surround.git
+ source = surround::git+https://github.com/kylechui/nvim-surround.git
sha256sums = SKIP
pkgname = neovim-surround-opt-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7b82ccf3da3b..06b6f1a007d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
pkgname=neovim-surround-opt-git
-pkgver=109.5970688
+pkgver=235.8f2af76
_pkgname=surround
pkgrel=1
-pkgdesc='Provides mappings to easily delete, change, and add paired "surroundings."'
+pkgdesc='Add/change/delete surrounding delimiter pairs with ease.'
arch=('any')
-url="https://github.com/tpope/vim-${_pkgname}"
-license=('custom:vim')
+url="https://github.com/kylechui/nvim-${_pkgname}"
+license=('MIT')
depends=('neovim')
makedepends=('git')
-source=("git+${url}.git")
+source=("${_pkgname}::git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/vim-${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
@@ -22,12 +22,14 @@ pkgver() {
package() {
- cd "${srcdir}/vim-${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
install -dvm755 "${pkgdir}/${_installpath}"
- cp -rvt "${pkgdir}/${_installpath}" doc plugin
+ cp -rvt "${pkgdir}/${_installpath}" doc lua queries
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}