summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--tabout.install9
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7265f611710e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-tabout-git
+ pkgdesc = tabout plugin for neovim
+ pkgver = r6.e8c369e
+ pkgrel = 1
+ url = https://github.com/abecodes/tabout.nvim
+ arch = any
+ groups = neovim-plugins
+ license = Unlicense
+ makedepends = git
+ depends = neovim>=0.5
+ depends = neovim-tree-sitter
+ provides = neovim-tabout
+ conflicts = neovim-tabout
+ source = neovim-tabout-git::git+https://github.com/abecodes/tabout.nvim
+ md5sums = SKIP
+
+pkgname = neovim-tabout-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a868d0fd5f0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-tabout-git
+pkgver=r6.e8c369e
+pkgrel=1
+pkgdesc="tabout plugin for neovim"
+arch=('any')
+url="https://github.com/abecodes/tabout.nvim"
+license=('Unlicense')
+groups=('neovim-plugins')
+depends=('neovim>=0.5' 'neovim-tree-sitter')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=tabout.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/tabout.install b/tabout.install
new file mode 100644
index 000000000000..899a54353c46
--- /dev/null
+++ b/tabout.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: You must manually set up this plugin in your init.lua/init.vim.'
+ echo ':: Check upstream documentation for more information.'
+ echo ':: A copy is installed under /usr/share/doc/neovim-tabout-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin in your setup scripts after uninstalling!'
+}