summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c01ccbcb515e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-togglelist-opt-git
+ pkgdesc = Functions to toggle the [Location List] and the [Quickfix List] windows.
+ pkgver = 215.e52ff67
+ pkgrel = 1
+ url = https://github.com/milkypostman/vim-togglelist
+ arch = any
+ license = custom:vim
+ makedepends = git
+ depends = neovim
+ source = togglelist::git+https://github.com/milkypostman/vim-togglelist.git
+ sha256sums = SKIP
+
+pkgname = neovim-togglelist-opt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3334b740c199
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=neovim-togglelist-opt-git
+_pkgname=togglelist
+pkgver=12.cafedc4
+pkgrel=1
+pkgdesc='Functions to toggle the Location List and the Quickfix List windows.'
+arch=('any')
+url="https://github.com/milkypostman/vim-${_pkgname}"
+license=('custom:vim')
+depends=('neovim')
+makedepends=('git')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+
+ cd "${srcdir}/${_pkgname}"
+
+ local _installpath="usr/local/share/nvim/site/pack/${_pkgname}/opt/${_pkgname}/"
+
+ install -dvm755 "${pkgdir}/${_installpath}"
+
+ cp -rvt "${pkgdir}/${_installpath}" plugin
+
+}